Jump to content
LaptopVideo2Go Forums

Acer 5520 Geforce 7000M GPU Overheats in games


co88dy

Recommended Posts

My 7000M in my acer 5520 is running extremely hot making it impossible to play almost any game. The idle temp is usually around 92 Celsius, and the gaming temp can be 110 Celsius+ in some instances, I checked my fps in Counterstrike and it came out to 4. I am sure the problem is with the GPU because I have reformatted, and used it in different fresh installs of different OS's. I cleaned my fan and heatsink (the fan was very dirty, this helped to drop the temp a bit). My heatsink has burning on it, which leads me to believe that it may no be conducting the cool air properly. So my 2 questions, 1 - Do you think replacing the heatsink would solve this problem, 2- do you have any other suggestions that may solve this problem.

Co88dy

Link to comment
Share on other sites

First off, let me say that is the hottest 7000m I have seen so far and if this problem continues, your gpu will be fried. What i suggest you do is this: Instead of replacing your heatsink (which I highly doubt you can), call acer and ask them to help you out with the problem. This is not the first instance of gpu overheating i have come across on this laptop. Good luck and I hope your problem will be resolved.

Link to comment
Share on other sites

Thank you for the quick response I just checked my warranty, and it is over on Jan 22, glad this didn't happen 6 days later. Anyway I will send it in and have them do what is necessary. I will update on what the problem was if they tell me.

Co88dy

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
Guest Kidder

i did experience with my acer aspire 5520 using the sma envidia 7000m gpu after a few weeks of having this problem i started to attempt to find the cause and the problem and found that the headsink had actually no connection to the chip and therefor the gpu was holding all the heat so i gently pressed in and held the headsink down on teh chip and results were fast and effective i went from 90+ drgrees to 60 - 70 within a couple of seconds

Link to comment
Share on other sites

Guest Kidder

since doing this i have managed to run css in high gfx at around 40 fps however before fixing the problem completely i did run css un directx 81 instead of direct x 90 do change the dx level go into steam select css then go into its advanced lauch options and add one of the following lines of code

-dxlevel 81

-dxlevel 80

-dxlevel 70

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...