Jump to content
LaptopVideo2Go Forums

Workaround for the Sleep Issue


Dox

Recommended Posts

As you may have all exprienced that some using desktop with modded inf and my own driver can cause an issues with "Sleep",

This problem is more prominent in the 18x.xx series drivers where some cannot wake up form sleep or crashes waking up from sleep etc.

Our good forum members has been brain storming and found a little workaround which seems to be working.

You can view their original discussions here

The Fix

You need to disable powermizer. There are a number of ways to do this:

1. Follow the registery edit guide found at NotebookReviews. This will work in XP and Vista.

2. If using my drivers you can download PowermizerSwitch tool. This will work in Vista only.

3. In XP only you can turn off Powermizer in the Nvidia Control panel without doing any of the above.

Notes

If you do not want to disable Powermizer then use a official mobile driver like 179.28.

If you have no issues obviously do not attempt to fix anything.

I am not 100% sure if this will work for everybody so please report your findings.

Link to comment
Share on other sites

Thans Dox for this Workaround

I have made some tests and here are the results:

First of all i have disabled Powermizer for AC Mode only

Clocking checked, so that it downclocks on Battery and stay at full power on AC

Just tested for Hibernate because Standby (full sleep) works right.

Some tests made for various usages:

Sleep and Wakeup with AC connected -> working

Sleep and Wakeup with AC after several minutes on battery -> working

Sleep with AC and Wakeup on Battery -> working

Sleep with Battery and Wakeup -> not working

Looks good for me except some driver problems with my Logitech G5

Driver would not detect mouse for right dpi settings.

Maybe cause by this driver

Environment:

Vista x64 Ultimate

GeForce 9500M GS with Dox Optimised 181.22 (Performance)

Would be great to get response

Edited by neokjo
Link to comment
Share on other sites

ahh thanks mate.

I'm not sure why the mouse settings should be affected by the Display driver.

Its sounds more like the mouse driver issue?

I have the same mouse btw.

Link to comment
Share on other sites

Open Regedit and go to \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{XXXXXXXXXXXXXXXXXXXXXXX}\0000\PerfLevelSrc

PerfLevelSrc key must be changed from 3333 to 3322.

PowerMizerEnable... from 1 to 0.

Set PowermizerLevel to 1.

Set PowermizerLevelAC to 1.

Reboot.

Link to comment
Share on other sites

Works great so far, I love it!!!! Ahhh i was waiting for this for months now. Thank you Thank you Thank you.

Link to comment
Share on other sites

lol... I've been saying this since December!! The fix is in my first post from here:

http://forums.laptopvideo2go.com/index.php?showtopic=22038

... disabling powermizer in the nvidia driver (3333 to 3322) that my laptop (LG R500/Vista64/4GB RAM) would wake up from sleep properly when plugged in. EVERY TIME! I just want to iterate that 3322 disables powermizer when on AC power. Then I tried to put the laptop to sleep in battery mode, and suprise suprise.... it froze when trying to wake it up.

So, I tried my theory out... I went into the registry and changed the powermizer setting from 3322 to 2222. Now ALL of powermizer is disabled (battery and AC). I try sleeping and waking up. Both AC and battery sleep and wake up properly at all times now!!! BUT... now theres no power saving for the video card.

It is DEFINITELY powermizer. and its ONLY found in the 180.xx drivers and up. All 179.xx drivers and lower do not have this problem. Having it on AC (with powermizer off [3322] with 180.xx and up) will always always wake up with no problems from sleep mode. This is proven by enabling powermizer with the setting 3333, and going to sleep, and it will definitely crash. Having a 180.xx+ driver with powermizer enabled on battery and not plugged in when going to sleep mode will make it crash. So, disabling powermizer while on AC, and remembering not to go to sleep mode while on battery (which is pretty useless) is the only workaround right now for 180.xx drivers and up. The latest driver that I tested is 179.28 that I know works perfectly, but recently there was another version in the 179 series.. I think it was 179.44, and I'm hoping to test that later after work. Hopefully Nvidia will hear us and finally fix this problem which is pretty serious.

I also found a fix for the people who have problems where if they run a game at a lower res than their desktop resolution, and after playing game X with the lower res, Windows, at some random time, will switch the desktop to game X's res... (Hopefully I get credit for this, unless someone else already posted a fix. lol) Its a service/task called TMM and it must be disabled. I've done this in Vista, it might work in XP, but not sure if TMM is there or not. This also fixes S-Video/Composite TV out problems where you would set it to output at this setting, and it would flash the image for 1/2 a second and then go black.

To fix these problems, go to control panel, administrative tools, and open the task scheduler. On the left pane, expand the Task Scheduler Library -> Microsoft -> Windows and open the MobilePC item. Click TMM in the middle pane. Click End in the right pane, and click Disable.

This worked for me, and everyone else I told so far, so it should work for you.

- YG007

Edited by YG007
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...