Jump to content
LaptopVideo2Go Forums

Acer 6920g faulty 9500m gs?


olihodgson

Recommended Posts

hi guys, pulling my hair out over this one. i have an acer 6920g with the 9500m gs. it is now out of warranty, i switched it off the other night, went to switch it back on in the morning, and everything fires up but no display. there is no display externally either, through both VGA and HDMI outputs, both throwing up blank screens. the computer is running in the background, i know when its at the login screen, if i swipe my finger it then signs into windows, logs onto my wireless network and can be found on my LAN network also, so i am sure windows is running fine, just no display. the first advice i was given was that the motherboard had given up, but if windows is running, surely this can't be the case?

i had tried a blind flash of my card, nothing happened, however, when i put the command in for an output file, it came back with no video display adapter found. Would this suggest its the graphics card? i did pull the card out and found a nice blob of silver conductor paint on the back, is this something acer did in production or do you think someones had a go at DIY in the past?

the other problem i am having is trying to find somewhere to supply a graphics card. i have found the same card from an indian seller on ebay, £130 plus delivery, but they cannot confirm the bios is correct for the laptop (although stating it has been tested in an acer machine) and i don't want to obviously buy a card to later find it won't work and i am a further £150 out of pocket.

any help would be very very much appreciated, i miss my laptop loads, having to use a 7yr old sony vaio PC at the moment, i'm suprised i got online with the thing, and i hate it. thanks in advance.

Link to comment
Share on other sites

i can confirm that some of the 9500m gs in the 6920G is faulty as mine died 2 months ago & just yesterday i received it back. the technician said that they sent it back to the manufacturer to change the graphic card. i doubt that the new one that the manufacter put in is really 'new' as i still sometime get some graphic corruption after a few hours of gaming (example 1.5 hours of GTA4) the screen would go crazy. some time many lines would appear. i thought its the LCD but i connect it to a tv using the hdmi port but the image is the same, corrupted image. i was thinking of the graphic overheating but even when i was just browsing the internet the screen would flicker a few times, messing up the colours, producing lines. all of these happen randomly. all this happens exactly the same like before the previous graphic card died. im afraid that the new card would die again.. btw unlike your case,you can still boot up into windows which i couldnt..

you ever overclock your 9500m gs before?use any other driver than the original?

Link to comment
Share on other sites

did not overclock, but did download and install the latest drivers from nvidia site, but that was about a month before the problem arose. When i opened the machine up, the rear vent was completely blocked with dust, it took a toothbrush to remove it all, it is now clear. i am probably going to go for the 8600m GT as its easier to find and cheaper, i am not a big gamer, any games i play i use my 360 for, i just want it up and running for my university work again.

i was also told that the 9500m GS is problematic, another reason why i can't be bothered to replace it like for like.

thanks for your reply, i hope you get yours sorted soon!

Link to comment
Share on other sites

i realise that the problem with the garble/corrupted image arise when i use newer driver than the original one (175.61) =S just now i use dox driver 185.85 the screen would flicker randomly and when im playing gta4 for atleast 30 mins, the screen would get corrupted. sometimes many lines appear. if im using the original driver the problem is gone.. i can play gta4 for hours nonstop, no lines or corrupted image problems..hmm.. if i have the money i'll try going for the 9600m GT if i can find a non ES card on ebay or somewhere.. or just yank one out from my classmate laptop which is the newer 6935G :) heheh kidding.

Link to comment
Share on other sites

paid £85 delivered for a 8600m GT, fitted it in now and everything seems to be working fine so far, lets hope it lasts. no idea if there will be much difference in general, but i doubt i will notice any difference. So to summarise, 9500m GS = SHITE! lol

Edited by olihodgson
Link to comment
Share on other sites

The 9500M GS is problematic because AFAIK it is the same G84 chip but 65nm instead of 80nm as the problematic 8600M GT.

Link to comment
Share on other sites

  • 3 years later...

Hi guys, I'm a new to this forum, only created account to get some help from you fellas. I been reading all here and elsewhere but I reckon my prob is different. Been using my Acer 6920g since last 4 years. In last week on one night I was working, if stopped suddenly. Meant it turned off. When I started again it won't boot, tried many times then turned on but giving startup errors and BSOD, different stop codes every time. Most of the time it would only powered on, but no display.(IT'S STILL DOING) I opened all laptop cleaned fan, RAM, there was bit of dirt, put back together, still no luck. It's completely uncertain, it would start sometimes, but freezes then restarts ok, or sometimes doesn't boot but only powered on. I can see and hear fan and HDD spinning. After lot googling, tried MEMTEST86 for RAM,(luckily it didn't turned off or froze until memtest finished) so RAM is good.tried to update bios but it just doesn't work, tried pulling bios Barry out and putting back, no good. Then I thought OS, but no luck cause I tried Windows 7 or Vista 3-4 times fresh installations, so HDD is good and no drama. I talked to my local professional repairs, he said must be graphic card, cause it freezes and no display on restarts mostly. Then googled and tried oven trick, lol But still same. In short it's fully moody, if it starts and run then good for 2-3 hours. Mostly at night it works better, but before sleeping if I shut it down or put it on sleep, morning the hell same. Sorry guys it's long story, but it's true. It happening. Making life so hard. I feel it's graphic card or something. Please help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...