Jump to content
LaptopVideo2Go Forums

official nvidia 186.82 strange behaviour?


tsunami2265

Recommended Posts

Hi guys & gals, just day before yesterday i installed the official 186.82 drivers from microsoft. Now after I installed the drivers I noticed strange fps issues. I own two games, Empire total war and AA3. I dont know why I was experiencing ridiculously low fps in Empire, I had to reduce some details which I never had to do so earlier. But the other extreme was that I got unbelievable fps increase in AA3. In some areas where I used to get something like 25-30 fps now i was getting more than 30, literally. I read somewhere that powermizer doesnt seem to work properly with the latest drivers. And because I play empire more, i reverted back to Dox 185.85. So now I get good fps in Empire but lower in AA3. I checked powermizer, the settings were alright but it seems it lowers the clock in some games when I use 186.82.

I couldnt do proper benchmarking cos I dont have 3dmark 06. Perhaps u ppl can tell me if 186.82 is really better off than dox 185.85 or should I wait for 191.xx? Or any suggestions if powermizer can be fixed.

I have dell xps1340 with 256mb 9500M DDR3.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...