Jump to content
LaptopVideo2Go Forums

Different problem with every nvidia driver (9600gt)


Guest rocknrollmops

Recommended Posts

Guest rocknrollmops

Hello, I am running into problems with most nvidia laptop drivers, which means that every driver gives me a different one.

I have a Zepto Mythos A15 laptop with a 9600gt built in, and I have tried several versions of nvidia drivers.

I tried the following drivers:

185.85 Dox Optimized (the driver that I had installed initially):

- Battlefield Bad Company 2 had pretty bad graphical glitches (pink flickering whenever smoke was visible, rendered the game unplayable)

- Battlefield Bad Company 2 and Bioshock 2 did not fill the screen in fullscreen mode whenever a non-native resolution was selected (black borders around the image)

then I tried...

197.25 (newest driver if I recall correctly)

- the (common) brightness issue appeared. The screen brightness is reduced and can't be increased to the maximum.

- (issues of 185.85 Dox stated above were fixed!)

now I have...

186.81

- graphical glitches in Bad Company 2 are fixed

- screen brightness is correct

- Bad Company 2 is not properly displayed in fullscreen mode, though (black borders)

As you can see, none of these drivers are perfect. I read on another forum that the version I am currently using (186.81) is the last version that is free of the common brightness bug. So is there a driver that fixes all of these problems, OR is there a workaround for any of the issues stated above (brightness or fullscreen bug)? I also tried to switch the scaling in the nvidia driver settings to force the game into proper fullscreen mode, but it does not let me do that. As soon as I apply the settings, they jump back to the default setting. Playing the game in native resolution is not an option because of the performance hit. Any ideas?

Link to comment
Share on other sites

Looks to me like your graphics card is probably in "No Scaling" mode. In the Nvidia Control Panel, you can change it to "Nvidia Scaling" or "Nvidia Scaling with Aspect Ratio" which should fix the black bar issue.

Link to comment
Share on other sites

Guest rocknrollmops

Looks to me like your graphics card is probably in "No Scaling" mode. In the Nvidia Control Panel, you can change it to "Nvidia Scaling" or "Nvidia Scaling with Aspect Ratio" which should fix the black bar issue.

I tried but it doesn't let me do that (as I stated above). When I select "Nvidia Scaling" or "Nvidia Scaling with Aspect Ratio" and hit "Apply", the setting automatically switches back to "Integrated scaling(...)" (I don't know what the option is called in english, it is the third one).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...