Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
mobilenvidia

Dell R720/SC8000 experiences

Recommended Posts

mobilenvidia

Last night, found an absolute bargain on NZ version of Ebay, Trademe
I've not received it yet, but might be here tomorrow according to trackntrace

What is the 'SC8000' I hear you say.
Well let me tell you
Its very basically a Dell R720
Called a Storage Controller or a Storage accellerator
Its designed to control a heap of Disk storage boxes, with up to 960x drives
The SC8000 has SCOS, Storage Controller OS a Dell propriety OS
Difference between the SC8000 and R720, SC8000 has NO
Drive Back planes
Internal SAS/SATA controller (ie H310/H710)

So only storage is either via internal/external USB, SD card or PCIe card/controller

My unit may have a LSI 9201-16e (not called that but is one) HBA SAS/SATA controller or possibly a LSI 9206-16e (this would be nice) HBA SAS/SATA controller (dual SAS2308)
May also have a DELL COMPELLENT SC8000 RAID CONTROLLER CARD
Both these cards come as standard with a SC8000
I can't tell as all I had to go by was a picture of the front of the unit
1088013779.jpg

Now I could have asked the seller what comes with the unit and more pictures but this unit was NZ$240 (US$160) delivered
I didn't dawdle and bought the unit straight away
Was a risk, but for $240 I can hardly go wrong, parts alone are worth more
Only specs I know of are:
2x E5-2640 v1 Hex Core CPUs 2.5Ghz base, 3Ghz turbo
8x8GB DDR3 1333Mhz DIMMs
Both are pretty well standard SC8000 configurations
Hopefully it arrives tomorrow  as its supposed to but not confident that it will
Would be nice to play with it over the weekend as weather not looking too good
I'll be back

Share this post


Link to post
Share on other sites
mobilenvidia

Had to wait till today to get the beast
And what a beast it is.
Bargain city $199 got me:

1x Dell Sc8000 server (R720 minus and drives/controller)
2x E5-2640 CPU's
64GB (8x8GB DIMMs)
2x 10Gbe LAN
2x 1Gbbe LAN
2x LSI 9206-16e Controllers
2x QLogic 16Gb Fibre Channel HBA's
1x cached RAID controller, special Dell one, no idea how it works

The 2x LSI9206-16e controller are pretty well worth what I paid for the entire server
The 2x Qlogic 2662's are but a $4400ea upgrade from Dell
Very pleased with my bargain.

I've added 8x 2GB DIMMs, now totaling 80GB
Also added a HP H220 HBA as I don't have any HD SAS (9206-16e) to SATA connectors (I could via an Expander)
Just going through the update firmware on the machine

But first impressions are very nice server, once it settles down its very quiet
The P4500 G2 makes a  complete racket compared with it

May need to rethink how I link the servers, the 16Gb FC HBA's I'll need to play with

More to follow, slow progress all this updating

Share this post


Link to post
Share on other sites
mobilenvidia

Another update

The P4500 G2 now has
2x Xeon L5640 CPU''s, Low power 6x Core 12x Thread @ 2.27Ghz (2.8Ghz turbo)
2x 4GB DDR3 RAM
7x 2TB 7200RPM SATA HDDs
1x HPE P420 RAID controller running above 7x2TB drives in RAID6 with 512MB battery backed cache
Intel 82598EB single Port 10Gbe card (onboard 2x 1Gbe network no longer works not sure if this card is the issue)
Windows Server 2019 trial

The R720 now has
2x Xeon E5-2640 CPU's, 6x Core 12x Thread @2.5Ghz
80GB DDR3 RAM
1x HPE H220 HBA controller, with BIOS and UEFI BIOS
1x 256GB Crucial SSD boot
1x 1TB Samsung EVO 860 SSD
NVIDIA Tesla M60 
Windows Server 2019

I've got both the P4500 G2 (DL180 G6) and SC8000 (R720) working together
The P4500 G2 I've setup an iSCSI target on the 9TB array
I can now setup iSCSI initiators on other computer to access this array as a local drive (Cool)

Still some issues to sort
The R720 won't boot to the 256GB SSD in UEFI mode, wonder if I need to clean the drive set to GPT then install Windows
The 2x 1GBE LAN ports on the P4500 G2 not working any more, not sure if broken or the Intel 10Gbe NIC is causing the issue

Share this post


Link to post
Share on other sites
mobilenvidia

Switched the Tesla M60 to Compute mode (both GPUs)
This changes the BAR to 8GB, all 8GB is addressable from the sever directly, not as in Graphics mode where only 256MB window is addressable
May cause some issues with VM and BIOS mode

Compute mode and a large BAR needs UEFI capable Mobo's as the addressing is 64bit also turns on ECC on the memory
No idea if it makes any difference but sounds good down the pub

Next I'll try and sort the above issues

Share this post


Link to post
Share on other sites
mobilenvidia

The P4500 still has both LAN ports with Code10 errors in Windows
Not sure what is going on here may need to boot to a Live CentOS USB and see what happens there

The R20 is great, getting to know it better enough for some Good and Bad

Good:
7x PCIe slots, 6x 8x electrical + 1x 16x but I also have the RIser3 GPU option riser which makes slots 6 and 7 into a 16x slot, where currently the M60 is as it sits nicely ontop of the PSUs
Quiet, this things is audible but so quiet compared to the P4500/DL160 G2, could have it in a room with door closed and not hear it, a bedroom you'd hear it
NIcely laid out inside the case, brackets to slide cables behind where the fans are, everything is easily accessable, excepting possibly internal USB and SD card slots
iDRAC has good display of whats going on inside the machine and some settings are configurable, lots of things to look at and play with
BIOS is good, heaps of things to look at and play with
UEFI even better as any UEFI compliant devices show up and can be gotten into their BIOS from here.

Not so Good
Boot time, takes for ever, the P4500 takes a couple of minutes, but the R720 mucks about for ages
It boots which takes a while, possibly slightly longer than the P4500, but then the LIfecycle process starts which takes just as long again
Turning this off makes little difference
iDRAC temp sensor, only issue I have here is the Case Exhaust temp, gives a warning below 8deg, Server is in garage where it can get below zero, not sure what happens below 3deg yet as this is critical temp, warning level below 8deg which its below most of the time
I can change the inlet temp warning levels but not exhaust

I've got coming from Ebay:
8x 2.5" backplane + cables, will allow me to run the SSDs inside the machine as currently power from external PSU
8x 2.5" drive trays for the above
Automatic fan controller, will attempt to wire up the 2x DL160 (1u) fan sets onto Tesla M60, its got 2x fans out, and a temp probe I'll attach to exhaust port of M60, no idea if this will work as fan speed is I take it controlled with lowering 12v line as only 2 wires are used
M60 running Folding at home at 68deg using server airflow (kinda blocked behind CPU, with the fans running should be able to bring this right down
 

Keeping my eyes on 2x XEON E5-2650 v2 CPUs, nice balance between power use and performance (8x core @ 2.6Ghz base)
Also need a couple of 1100w PSU's to run the M60 from inside the case, currently running the 8pin power connector from external PSU
DVD drive cable also would be nice, as this is also powered from external PSU, these are not cheap

Share this post


Link to post
Share on other sites
mobilenvidia

My bargain SC8000 is no longer such a bargain 😞
I received 2x 1100w power supplies to run the Tesla M60 from inside the server instead of via external power supply
I plugged in the M60 into the PCIe riser board 8pin power supply, turned on server and then smell of smoke, quickly turning every off
Smell of smoke coming from the 8pin connector on the M60
Server won't power up, iDrac complains 3.3v out of spec
Tried all sorts of stuff, but assume the Mobo has died, some very small metal bits came of the motherboard when I removed it

Don't know state of the M60 yet

New motherboard coming from the US, this will make the the server a R720, no longer a SC8000
Motherboard currently on a very long journey from Oakland CA to Erlanger KY where it will fly out from, but probably via LAX almost back where it began
It due here on 16th Sept, but now thats its in Erlanger may get here before then.

I've ordered a DVD drive power and data cable to also get this powered from inside the case
vFlash card I ordered (16GB), I got a 1GB card, they are sending a 16GB version, good service they just sent it with no questions
IDE to SATA converter arrived so I could use my trusty IDE DVD burner I've had forever, didn't make any difference in DVD to MP4 conversion bottleneck I think is the CPU speed
Still waiting on my FAN speed controller, not sure if this will be needed any more as I'm thinking the M60 might be a dead duck, need to resurrect a Mobo and CPU to see it will come to life

I need to sort out why the GPU/PCIe power short circuited
I had the M60 plugged in before (but in a different Riser) and server complained the 1100w PSU's are needed to use the 8pin power supply on the risers
Hopefully I can sort the issue before I try again, once burned twice shy

Share this post


Link to post
Share on other sites
mobilenvidia

Yeah, I'm back, now have a R720, new motherboard all working good
Just updating Firmware and updating everything
But good to have this working again

Worked out issue with GPU
The PCIe riser cards in the R720 have the power out reversed over to what the GPU power connector has
Seems to match Power supply out
Modified a PSU to 6 pin power plug (M60 needs 8 pin plug), can't test to see if M60 working till I setup the boot SSD with Windows
Am hopeful, quite a trap for the unwary the reversal of 12v and Ground pins

One bonus Mobo came with Dell Perc H710p mini SAS RAID Controller

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...