Jump to content
LaptopVideo2Go Forums

Forceware & detonator/dell 8500 backlight problem


Guest razornitefire99

Recommended Posts

Guest razornitefire99

i am creating this topic to consaladate all the information we know about the backlit problem that the dell inspiron 8500's have had with their nvidia 4200 go. as far as i can tell the problem is with the forceware edition of nividia's drivers and still to this point there is no fix. the last driver that the backlit worked correctly was the 52.13 driver but that does not include any of the new features that the 56.64 drivers offer. it seems to me that neither dell nor nvidia have much intrest in anyone who has a 4200go becuase as far as i can see there havent been driver updates in 6-7 months. if everything that i have heard is correct then cant we modify the drivers themself (insead of just the inf) to achive a correction to our backlit problem? i would take it that there is something in the older detonator drivers that maybe we could take and mod into the new forceware. i am sure none of us 4200 users would mind helping out in any way we can to get this problem fixed. and hey maybe we could start some kind of petition to send to dell to get the drivers updated. together we are strong. :) :)

Link to comment
Share on other sites

There are two things that have worked for some people (and seem to be working on my Inspirion 5150).

1. There's a registry fix in our Downloads section that might help. (It requires a reboot to take effect.)

2. Add the following line to the [nv_SoftwareDeviceSettings] of your INF, if it doesn't already have it:

HKR,, MapOSD3ToNV, %REG_DWORD%, 3

Then reinstall.

Those are the only things we know of so far and we've seen messages saying they don't work for everyone with the 56.xx drivers, so please let us know how you make out.

And if anyone discovers any other fixes, please let us know. Thanks!

Link to comment
Share on other sites

Guest razornitefire99

just to let all the people with geforce 4 4200 go's know the 47.12 drivers with the new mod INF works pretty good. it fixed a problem i was having with getting legacy of gain to work and the backlit works properly again. i havent tried the open/close lid or if there is big performance incresses but from what i can tell its working very nice. personally its nice to get rid of the 44.XX drivers.

hope the drivers help all u other 4200 go peeps.

john

Link to comment
Share on other sites

Guest big_gie

using drivers v56.64 with inf v20.22. I'm only having problem with the display not shuting down (only blanks but still on...)

I will try the v47.12 with v20.22 inf to see if it works...

EDIT: v47.12 enable display shutting down. Hibernation works too.

Those are the latest I've seen wich fully works (I didn't try many though...)

Link to comment
Share on other sites

Guest Nerdtalker
just to let all the people with geforce 4 4200 go's know the 47.12 drivers with the new mod INF works pretty good.  it fixed a problem i was having with getting legacy of gain to work and the backlit works properly again.  i havent tried the open/close lid or if there is big performance incresses but from what i can tell its working very nice.  personally its nice to get rid of the 44.XX drivers. 

hope the drivers help all u other 4200 go peeps.

john

How do the 47.12's do performance wise? The fastest drivers for the 4200go (from what I've seen) are 44.03's. I'd also really like to see this backlight issue fixed, especially because the 5x.xx's result in increases in pixel-shader peformance.

Link to comment
Share on other sites

Guest big_gie

I don't know for the perfomances. I don't play much of games and never tryed to benchmark. Also, I'm pretty new to this inf mod thing. I was tired of not getting updates from dell andfound this site. Really nice :)

I would also love to see a workaround... Their MUST be something...

Link to comment
Share on other sites

Guest razornitefire99

when i was playing unreal 2004 i couldnt notice a performance diffrance but i bet if u look at benchmarks the performance will be slightly lower. but over all there is more stuff the 47.12 drivers can do. i would really love to see some 5x.xx drivers that would work on the 4200's but alas still nothin that lets the backlit work correctly. also has anyone tried the new 56.63 mobile driver with a 4200. im intrested in seeing if anything worked with it.

john

____

corrected the version

Edited by dontknow
Link to comment
Share on other sites

  • 2 weeks later...
Guest razornitefire99

OK got some good news and possibly some bad news. the good news is the new 60.72 drivers with the 20.33 fix the backlit problem in the 8500 w/ 4200 go's . the bad news is i dont have enough time to test it any further. can some one test to see if it gives good performace too. i would hate for it to suck as a driver just to get the backlit fixed. hopefuly all the 6x.xx series will have the backlit fix and dell will get its act together and make a new 4200 driver for us. :) :) :P

Link to comment
Share on other sites

nice news. so it's really the driver which caused the backlight problem.

Link to comment
Share on other sites

Guest Solo761

Just downloaded 60.72, it fixed backlight problem for me too. Ran 3DMark2001 and got 8045 3DMarks (Point Sprites looked funny, kinda... point-Y :) ) which is significant drop compared to ~9100 with 43.03, but not compared to 5x.xx. They probably removed 3DMark2k1 optimizations that 4x.xx had. Also run UT2k4 benchmark (I attached "bat" file that I use) and got almost same result as with 43.03

43.03 - Score = 55.648640

60.72 - Score = 55.522457

Mov_UT2_intro.bat

Link to comment
Share on other sites

Forgot to write my system :) , that should be settled now.

BTW.

I made this "bat" file because others that I found on the net were botmatch becnhmarks and I had to play or it would just sit there, and since it's kinda hard to play the same every time I started it (not to mention that bots don't). This is becnhmark that uses intro map so it allways plays the same.

Link to comment
Share on other sites

Yeah this is good news, a pity that the benchies are a bit slower though.

But these are only beta drivers, and will be sometime before the any decent drivers come out.

At least they work, I just can't get 60.72 to work for me.

Pieter

Link to comment
Share on other sites

60.72 doesn't work for me either as far as resuming from standby is concerned. The system turns back on but the screen stays black. This is on a Dell Inspiron 8200 w/ Quadro4Go GL 700 running WinXP SP1.

Link to comment
Share on other sites

Guest Pilchard

Howdy!

I have an inspiron 8500 with a 4200 go.

I have had the bcklight problem (going bright white when lid peg is pushed down) with the forceware drives, (detonator was ok).

Just tried the 60.72 drivers with the 20.33 inf and all seems well!

The lcd goes off ok, and standby resumes ok!

Rockin!!

Thanks guys :)

Link to comment
Share on other sites

  • 1 year later...
Howdy!

I have an inspiron 8500 with a 4200 go.

I have had the bcklight problem (going bright white when lid peg is pushed down) with the forceware drives, (detonator was ok).

Just tried the 60.72 drivers with the 20.33 inf and all seems well!

The lcd goes off ok, and standby resumes ok!

Rockin!!

Thanks guys :)

Hi there. I am running an 8500. I've pretty much lived by the 44.03 except for a few issues..

I've reformatted my computer for the first time and the current Dell drivers are causing constant shut off of my laptop.

Where would I go about downloading the nvidia 60.72 and the 20.33 inf??

I appreciate the help guys.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...