Jump to content
LaptopVideo2Go Forums

Problem finding a good driver for HL2, anybody?


Guest Joel

Recommended Posts

I have a problem with my drivers. I use a toshiba p10 Notebook.

3.0GHZ P4 HT

512mb

Geforce FX 5600 GO

My problem is such, I use the Nvidia 56.72 drivers with the modded INF (the original modded inf which first appeared on this site, so not the new infs)

This driver makes most games run pretty smoothly, such as Sims 2, even Halflife 2.

When I try new drivers, well newer drivers I get major lag on all those games. They just chug like CRAZY! The only other driver i have found so far which gives SIMILAR performance, but not quite are the Official Toshiba 44.85 drivers... they seem quite good.

But I need someone to recommend me a newer driver, as I am beginning to see problems with newer games. Halflife 2 for example with hte 56.72 has graphical errors on some objects which appear white...

Then with Fifa 2005 I experienced crashes which are often fixed by updated drivers...

Are there any newer drivers which I should give a try on my system?

Please let me know... or what difference the Infs make (the new ones for the 56.72)

maybe if I just try different infs...

Anyway, some help would be great as Im at a loss of what to do!

Thanks!

Edited by dontknow
Link to comment
Share on other sites

Now reports are more often that there is a kind of certain LAG on some Laptops. I don't understand what is going here. We never had reports before.

Link to comment
Share on other sites

What do you mean a type of certain lag?

I just find games ###### stuttery with most other drivers...

But there ###### well MUST be a reason for it!??!?!

I mean surely these new drivers are BACKWARD compatible, I mean perhaps they dont improve performance but why the hell should they make it SOOOO mcuh worse?!

Anyway... if anyone knows a good driver, newer one which might work, PLEASE let me know!

thanks guys

Link to comment
Share on other sites

Joel, a lot of gamers are finding that 67.02 is an excellent driver for both speed and image quality. It should be at least as fast as your 56 series driver. It might be worth a try.

Link to comment
Share on other sites

Hi!

I'm the "other poster" that dontknow is referring to (among others at least).

I have the exact same configuration on my Acer Aspire (P4 3.06GHz, 512RAM, GeForce FX Go5600 128MB). I'm having the most sluggish time with running many of the newer games (FarCry, Call of Duty, MoH: Pacific Assault).

The stangest thing is that I just bought HL2 today, and THAT is running like a charm, even in 1280x1024... (on modden 66.93 driver).

My experience is that it doesn't really matter (for ME) which driver you use... I've tried a lot of the drivers on this page (always changing to the newest when it is released) For me, either the game starts or it doesn't. Thats acctually why I started visiting this exellent page (thanx dontknow :) ) because some games don't run at all with old drivers, and the morons at Acer don't produce newer drivers for their laptops.

I really don't know why some games (ie. HL2) run like a charm that are even more advanced than some other games (ie. MoH: PA). I guess it has to do with the graphics engine for that specific game.

Guess I didn't really help that much though... :)

Link to comment
Share on other sites

Alright IM going to try those 67.02 drivers right now.

Well the problem with me is as I explained, the games start alright, but they just lag. I tried HL2 with those older drivers I was talkin about, runs pretty ok apart from some grahics glitches (thus the need to update), then I install the latest, and goddamn it lags like crazy, as though I was running it on half the minimum specs, its literally not playable anymore... its very VERY strange.

Anyway, another off topic question, which infs do u guys download? THe Perform ones or the other ones?

What does it actually mean when theres Perform after the inf???

Link to comment
Share on other sites

Is there noone else whose had a problem like this?

Like i said I tried the new drivers but still no go... its very odd...

Is anyone here playing HL2 well?

It looks good for me, except for these odd graphical glitches, and if I get newer drivers I have to scale the settings massively...

But if I get newer drivers, which infs should I use?

Performance infs?

Link to comment
Share on other sites

Yes, start with the performance inf, then try the others if you run into problems.

Link to comment
Share on other sites

But there just has to be a reason why new drivers dont work? Its virtually the only driver set Ive found and ive tried lots which works!!!

Other than the official Toshiba ones... but theyre 44.85 so pretty old......

What could be the cause of this ?

Link to comment
Share on other sites

Guys, heres an update:

I installed the 56.55 drivers, and they run just as well as the 56.72 drivers.

Is it possible that my card just doesnt like the 60+ drivers...? What could possible cause this weird prolem...?

WHat do you guys recommend I do? Send my laptop into Toshiba...?

I am a bit lost as to what I should try now...

Thanks

Joel

Link to comment
Share on other sites

Just start the game and DON'T edit or alter the automatic detected graphic settings in HalpFlife1. Look for the stars at the settings (*). These are your recommended setting detected by the game for your system.

Also use 67.02 and try to update (if available) your soundcard driver.

Link to comment
Share on other sites

Sound processing also affects gameplay or *can* be responsible for lag in games.

Link to comment
Share on other sites

ARGHHHHH! I tried what you said, I found some ###### new sound drivers, work fine, installed those drivers with performance inf and normal inf. I get nothing...

It just runs crap! Virtually the entire 60+ series! This cannot be normal! WHAT THE HELL AM I SUPPOSED TO DO :) Im going to go cry soon! lol

Link to comment
Share on other sites

HL2 was reported to have a stuttering issue when auto saving in some areas... they will be releasing a fix for that. Would that be an HL2 issue that you've been having?

Link to comment
Share on other sites

Nah, I have that problem but I think everyone does, like you say its just when it saves it freezes for about.. 2 - 3 seconds.

No I mean just playing normally, it runs at about 4 FPS at the most... its awful!

(but not with the drivers before 56.72), kjust with any newer drivers I've tried!)

Link to comment
Share on other sites

What software do you have installed? Disable AntiVirus for the time playing and make sure you don't have any CPU/GPU throtteling (Intel SPeedStep or Toshiba PowerSaver) active. Buy yourself a 7200rpm HD :)

Link to comment
Share on other sites

Hey, well I dont have any of that stuff, all I have is Toshiba Energy Management (thats the thing which tells you the battery level of your battery, as well as changes modes if u remove the power cable...

No virus scanner or anything...

Link to comment
Share on other sites

  • 2 weeks later...

Hi,

I have tested ALL modded and official drivers on toshiba laptop :

- The toshiba latest release works quite good but is old : got 1800 in 3DMark03

- All the modded drivers are VERY slow : 400-500 in 3DMark03

- The official nVidia 56.77 works very good : 2300 in 3DMark03 but some white textures in HL2

Any solutions out there ???

Link to comment
Share on other sites

Hey man am I glad it isnt just me that has that problem!!! PHEW!

So you use 56.77 totally Unmodded? Just the normal install from nvidia?

I have the 56.72 from this site with the standby fix, that works just fine for me too, but yeah white textures in HL2!

Surely, therre must be a reason, I mean i wouldnt mind so much just ###### well knowing what exactly makes those new modded drivers NOT work on my lappie!

Edited by ®®®
Link to comment
Share on other sites

I would really want to know what's wrong with our laptops :-/

You canfind the nVidia official laptop driver here : http://www.station-drivers.com/page/nvidia...eforce%20go.htm

I'm trying to investigate further...

Patrick Colis

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...