Jump to content
LaptopVideo2Go Forums
Sign in to follow this  
Bob the Dino

LCD SEC3255=1600x1200 shows only 1400x1050

Recommended Posts

Bob the Dino

I have two major problems with my Geforce 440 Go 64M in my Inspiron 8200.

First, when I use devcon.exe, it reports my DEV_ID to be 0174, when it should be 0179. I am sure I have a 64M card, and programs like SiSoft Sandra say I have 64 Megs of RAM on my card.

Also, right now I am using the 44.68 drivers fine, but whenever I try to upgrade to 6x or 7x drivers, it boots up into XP, but only the top left 1400x1050 of the display is used. To the right of the working display there are a bunch of colored lines. It won't let me switch to 1600x1200 either. Is there any way to force the drivers to see my display as 1600x1200 so I can use newer drivers?

Thanks for any help

//edited again the title to reflect what happens here

//added quick resolution below

Add this line to an INF. It needs to be one long line placed before NV_Modes after [nv_SoftwareDeviceSettings]

HKR,, OverrideEdidFlags0, %REG_BINARY%, 
3A,C4,00,03,00,00,FF,FF,04,00,00,00,00,7F,00,ff,ff,ff,ff,ff,ff,00,4c,a3,55,32,00
00,
00,00,00,0d,01,03,80,1e,17,78,0a,ad,75,96,57,52,89,27,23,50,54,00,00,00,01,01,
01,01,01,01,01,01,01,01,01,01,01,01,01,01,48,3f,40,30,62,b0,32,40,40,80,6e,11,
30,e4,10,00,00,19,00,00,00,0f,00,00,00,00,00,00,00,00,00,19,af,02,32,00,00,00,
00,fe,00,4d,31,36,33,35,02,31,35,30,55,32,0a,20,00,00,00,fe,00,e6,d6,c0,a9,8a,
67,43,00,02,0a,20,20,20,00,38

Edited by Bill

Share this post


Link to post
Share on other sites
®®®

Devcon.exe is reliable. 0174 is also available with 64MB.

Uninstall properly 44.68, use a driver cleaner or manually search/delete the registry entries, reboot. Install new driver.

Share this post


Link to post
Share on other sites
Kamika007z

A good driver cleaner which I suggest using would be Driver Cleaner 3.3

You can download it here:

http://www.drivercleaner.net/

From there, download the setup file, install and run it and choose only "nvidia" (without quotes). After cleaning, make sure you reboot and install the drivers.

Let us know how it goes :)

Share this post


Link to post
Share on other sites
Bob the Dino

Uninstalled the drivers, and used Driver Cleaner in safe mode, but it's still seeing my display as 1400x1050. :/

Everytime I install any drivers, the computer also automatically installs drivers for two monitors, "Default Monitor" and "Plug and Play Monitor". It seems like the "Default Monitor" can go up to 1600x1200, but it only lets me use the "Plug and Play Monitor" as the active monitor, which has the incorrect maximum resolution.

Share this post


Link to post
Share on other sites
Bill

First of all it is reporting your card correctly, as it is indeed a 0174. (mine is aswell)

While your screen might be a bit different than mine, you could try the driver and INF I am on, (links in sig) or you could try this new Dell INF I modded for the 67.65 driver.

http://forums.laptopvideo2go.com/index....t=0entry12543

It has Dell specific settings, so it should work correctly with your screen.

Hope this helps.

Bill

Share this post


Link to post
Share on other sites
Bob the Dino

67.65 with your inf didn't work either... I seem to only have this problem with the 6x and 7x drivers, all of the 4x and 5x drivers have worked fine.

Share this post


Link to post
Share on other sites
Bob the Dino

Also, I just noticed this, I don't know if it would be the reason the later drivers are acting up, but the 44.68 drivers that I am currently running do not seem to recognize my chipset, so it won't let me use AGP. I've tried running the Intel INF Updater, but it still won't let me use AGP.

Share this post


Link to post
Share on other sites
Bill

Do Dell's latest drivers (42.58) let you use AGP?

Share this post


Link to post
Share on other sites
®®®

The Intel INF Update Utility don't let you choose AGP? How can i understand this? It's not the VIA Chipset installer (there you can choose) :) It don't let you choose, it just installs itself. I must guess there's something totally different wrong with your Windows setup, sorry.

Note: i changed your SystemSpecs Profile to 'GF4 440 Go 0174 '

Share this post


Link to post
Share on other sites
Bob the Dino

Sorry for not explaining more. I installed directx 9.0c before I installed the Intel INF Update, so it kept saying that my chipset was "not detected", and I couldn't change the AGP settings at all. I had to reinstall Windows and run the Intel INF Updater first, so now I can use AGP, but unfortunately all of the newer drivers still read my monitor as 1400x1050. :)

Also, I just noticed the 44.68s detect my display as a Samsung UXGA (SEC3255), but the newer drivers see it as a nVidia Flat Panel (NVD0300). I tried the Toshiba black bar fix for 1600x1200, but it didn't work.

Share this post


Link to post
Share on other sites
Bill

You are going to need your own fix, you will need to revert back to the drivers that detect it correctly, then provide us with some EDID information or something, as for exactly what you need to tell us, or how to find out, I am not sure, but that is how they fixed the toshiba problems, with edid fixes.....

Share this post


Link to post
Share on other sites
Teraphy

So that is how the SEC3255 comes into play. Let me reiterate for clarity that with these new drivers you are getting a lower resolution (1400x1050) than your desired resolution (1600x1200)?

I'm sure this can be fixed but not with the Black Bar fixer.

Share this post


Link to post
Share on other sites
Bill

Fixing it is similar to the black bar right?

Or am I completely off track here......... :)

Edit: I know an EDID override would fix it......

Share this post


Link to post
Share on other sites
Teraphy

Overriding the EDID is one way but there is another which I always thought was a restriction but I am now proven wrong.

Bob, add the following line to this section [nv_SoftwareDeviceSettings]:

HKR,, NV_R&T,  %REG_MULTI_SZ%, "R&T0000=1600,1200,*,62,*,SEC3255,OEM,16200,2160,64,384,1250,6,30,--"

I understand all but the following in this line: 64,384 and 6,30. Got me on how those were calculated.

Share this post


Link to post
Share on other sites
Bob the Dino

I tried adding that line to both 67.03 and 67.50 drivers, but it didn't seem to have any effect with either.

Share this post


Link to post
Share on other sites
Teraphy

Hmm

I guess the "NV_R&T" is for Win2K, while this is supposed to be WinXP ... though for some reason I doubt this will work either. Despite the registry entry being in the NVDM.inf file itself.

To be placed just before Nv_Modes.

HKR,, NV17_Modes,  %REG_MULTI_SZ%, "R&T0000=1600,1200,*,62,*,SEC3255,OEM,16200,2160,64,384,1250,6,30,--"

Because I'll go back to my original thinking that is restricting or setting timing for available modes. Either that or because it is attempting to match with "SEC3255" you can just replace it with what is being found "NVD0300"

HKR,, NV17_Modes,  %REG_MULTI_SZ%, "R&T0000=1600,1200,*,62,*,NVD0300,OEM,16200,2160,64,384,1250,6,30,--"

Have you tried the original nvdm.inf file supplied in a driver containing "oeminfs"? (non-Pieter modified) 67.42 is an example.

Share this post


Link to post
Share on other sites
Darmdorf

Thank you Pieter for pointing out this particular thread. I thought it was about time for me to finally bite the bullet and register - especially after having silently read along for ages! The time has come for me to become actively involved and offer my own 2 cents. :)

This thread deals with a personal peeve I've had with Dell for years now. As most of us know, the newer Nvidia drivers max-out the active display area of UltraSharp displays in C-Series Dells to the upper left 1400x1050 pixels, instead of the true physical resolution of 1600x1200. From what I've been able to piece together so far, the problem is definitely related to the Samsung display, and thus the registry references to a PNP monitor type "SEC3255" which evidently comes from the EDID information of Samsung displays. That is information about supported resolution and frame rates the display is able to handle, that it responds with when interrogated by the host operating system as a PNP device. One fellow even thought it may even be limited to a specific upgrade level of the Samsung UltraSharp displays. Evidently other compatible UltraSharp displays from Sharp installed by Dell are not affected by the problem. Whether other manufacturer?s notebooks are affected?

OK, so what works? I just learned from a similar thread in the Latitude Video section of the Dell user forum, that another poor soul with a Samsung SEC3255 display managed to get Pieter's 60.60 driver working straight off. I tried it last night and **Breaking out the Champagne** HE WAS ABSOLUTELY RIGHT!! Pieter's INF for 60.60 was in respect to the newest versions rather plain vanilla, without the D3D and OGL tweaks - but Half Life 2 squeaked along just fine at 1600x1200 and medium settings. Hallelujah!

What doesn't work? Evidently anything newer than 60.60, where the Samsung UltraSharp display is involved!! Or can someone refute that?

And why? Bloody good question! It would certainly seem to have something to do with the inner workings of Samsung's EDIDs on this particular display, as Teraphy seems to think too. Otherwise Nvidia wouldn't have gone to all the trouble to include that special "NV_R&T" entry in the NV17 sections of its newer INFs, which evidently attempts to override the Samsung's faulty EDID data. In those cases where the installation of newer drivers cause the problem, the pesky "NVD0300" monitor entry Teraphy mentioned is ALWAYS active in the registry -- and has the max resolution of 1400x1050! I took the trouble to install 60.60 with the stock Dell INF (with the NV_R&T entry) and then Pieter?s (without), and both worked normally. As a seasoned software engineer I naturally had to tinker around as best I could with the registry settings -- but to no avail. The logic involved is simply well shrouded and guarded by mist.

It would be SOOOOOO..... nice for us to finally find the mechanisms with which we can finally squash this bloody bug!! There are untold legions of unwary Samsung display owners enjoying really great screen quality, but stuck with pre-historic gaming support. This is the place, and you're all the right people with the right stuff. Let's finally be the ones to do it!!

Greetings from old Germany,

Doug

P.S.: The Geforce4 440 Go cards used by Dell all seem to be decoded as 0174, and not 0179. The 64 MB versions for Inspiron & Latitude seem to have Subsys types of '00D41028' & '00D51028' respectively. The Latitude's system BIOS must be able to mask in the appropriate bit into the PCI hardware register, as the cards themselves are identical.

Share this post


Link to post
Share on other sites
Teraphy

:)

* Toshiba with 4Go's are affected with a similar problem.

* R&T is useless because it only supplies timing for AVAILABLE modes and it does not add modes. 1600x1200 is not an available mode by any means.

As I am aware this is how the modes are gathered:

-> mode lists read from INF

-> obtain EDID from all connected displays (fails)

-> user created custom modes

During the obtaining EDID process it is clearly failing. With my 2Go it never obtained a proper EDID and always resorted to NV0200. I am aware Dell BIOSes have not been as faulty as Toshiba ones so I'm curious to why this is the case. If you are willing to part with a copy of your BIOS I would love to take a look at it to see what is happening.

See thread Backing up mobile BIOS

My question right now -- is it confirmed 60.60 is the very latest useable? (60.72, 60.80?)

Perhaps we'll open a Dell thread to which data can be collected on this matter. In the end the quick fix looks like it will involve an EDID override just like the Toshibas.

Share this post


Link to post
Share on other sites
mobilenvidia

Welcome Doug to the darkside,

If Teraphy can sort the Toshiba problem (without a Toshiba), I'm sure we can do the same here.

Teraphy we should start a new thread (pinned) for just this problem.

Gather some more info from others with the SEC3255.

Share this post


Link to post
Share on other sites
Darmdorf

Hi Pieter. Glad to finally become an active part of your community. I know you spend literally gobs of /family hours on this project for all the worlds 'Nvidia damaged'.

During the obtaining EDID process it is clearly failing. With my 2Go it never obtained a proper EDID and always resorted to NV0200.
I think you're absolutely right there. I stumbled upon a few EDID tools through 'Google':

1. Phoenix EDID Designer V1.3 It can display the EDID data from the registry in meaningful form.

2. read-edid V1.4.1 This is a tool to directly readout the EDID data from the display in a Linux and Dos flavor. The Dos version with a parsing tool can be D/L'd here.

I took the time to actually try reading the EDID with read-edid under Dos with the following success:

VBE/DDC service about to be called
[tab][/tab]   Read EDID

[tab][/tab]   Performing real mode VBE call
[tab][/tab]   Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
[tab][/tab]   Function supported
[tab][/tab]   Call failed

The EDID data should not be trusted as the VBE call failed
EDID claims 144 more blocks left
EDID keeps on claiming same number of blocks left. Corruption?
Reading next EDID block

The poor program goes into a loop trying to readout the EDID.

As you can see from my profile, I'm using the last standard Video Bios which you've already collected: Ver. A6 4.17.00.55.C2 from 24-FEB-2003.

In the end the quick fix looks like it will involve an EDID override just like the Toshibas.

I think you're right here again. I read through tentonine's thread where he also mentions the use of 'edidoveride' to fix his Quadro4 700 display problem in the opposite direction. I think I understand the mechanism, but I don't have the foggiest idea what the appropriate data would be (part of the SEC3255 EDID data?). There he also mentioned that the display model description is also within the 'Device Parameters'. I found "2R2902150U2" there for the SEC3255, and I think that may very well be valid for a Samsung part.

I also happened to look at your INF Enhancer. Nice tool.

Thanks again for your expertise.

Edited by Darmdorf

Share this post


Link to post
Share on other sites
Teraphy

I'll give the Phoenix EDID a go, never ran across that one. I have run across the read-edid which does fail on LCD's.

As for the BIOS :) I can't find a copy of that particular version. Oh well. I do have 55.AX BIOSes but that is it for the 55 revision.

But anyway, this would be the steps to create an override key.

Obtain the 128 byte SEC3255 EDID code.

Locate bytes 54-72 (exactly 18 bytes long)

Place those 18 bytes within the following reg key

HKR,, OverrideEdidFlags0, %REG_BINARY%, 3A,C4,00,03,00,00,FF,FF,04,00,00,00,36,12,[ insert 18 bytes here -- comma seperated ]

Done. As long as NVD0300 is the EDID you are currently obtaining.

Thanks for the comment on the Enhancer. Positive remarks always appreciated :)

Share this post


Link to post
Share on other sites
Bob the Dino

#@!#!@ It worked! :)

HKR,, OverrideEdidFlags0, %REG_BINARY%, 3A,C4,00,03,00,00,FF,FF,04,00,00,00,36,12,48,3F,40,30,62,B0,32,40,40,80,6E,11,30
E4,10,00,00,19

I added that into the INF. The only strange thing was that when I booted up the resolution was at 1600x1024, and I had to uncheck "Hide modes that this monitor cannot support" to get 1600x1200, it works fine, except I tried one game, and it wouldn't let me set the resolution to 1600x1200, only 1280x960 max. This happened with the 67.03.

Share this post


Link to post
Share on other sites
Darmdorf

@Teraphy: Just a few more questions.

1. Would that 'OverrideEdidFlagsn' be something one could pop directly into the registry after a rotten installtion to correct things, or would it only function from within the INF itself? If the latter, it would suffice to simply place it in any and all INFs to make them function correctly with the SEC3255?

2. What is the "proper" value for n here? I assume the first such entry starts with n=0, the next n=1, and so forth? But the Dells would only need just one, right?

Here we have my correct EDID data from the SEC3255 display:

"EDID"=hex:00,ff,ff,ff,ff,ff,ff,00,4c,a3,55,32,00,00,00,00,00,0c,01,03,80,1e,\

  17,78,0a,ad,71,96,57,52,89,27,23,50,54,00,00,00,01,01,01,01,01,01,01,01,01,\

  01,01,01,01,01,01,01,48,3f,40,f0,61,b0,32,40,40,80,6e,11,30,e4,10,00,00,19,\

  00,00,00,0f,00,00,00,00,00,00,00,00,00,19,af,02,32,00,00,00,00,fe,00,32,52,\

  32,39,30,32,31,35,30,55,32,0a,20,00,00,00,fe,00,e2,b4,93,77,4e,2e,0f,00,02,\

  0a,20,20,20,00,79,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\

  00,00,00,00,00,00,00,00,00

3. Does one start with byte 54 (starting with byte 1:01,48,3f...00,00) or byte 53 (starting programming style from byte 0:01,01,48...10,00)?

Looks like we're making decent progress here. I also passed on my Rom file to Pieter should you need it. Incredible group here! :)

Share this post


Link to post
Share on other sites
Teraphy

I'm glad to hear it works :)

@Bob, the EDID now acts like something you need which means I assume it acts like it would a normal display. I truely don't know if this is just for display only. I would gather any program would set available modes given by either Windows mode listing or hard coded. Have you tried visiting the Display Properties dialog and Settings tab to see what Windows allows? It sounds like you attempted with the NV control panel ("Hide modes") which might be different. Just a thought.

Has the game allowed higher resolutions from other drivers? I would guess yes if you are talking about Half Life 2 like you mentioned prior.

@Darmdorf

It is recommended to be placed in the INF as that registry is placed in an obscure area and is random. You simply could add it as long as you know where to place it. The GUID is the random value located here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{GUID}\0000\{DWORD value goes here}

The GUID you want is the one that is simply found by finding the "0000\VolatileSettings" subkey.

The proper value for N is 0. If 0 isn't found the override is passed over. Up to 4 (?) keys (0-3) can be used.

As long as the Dells don't use another NVD0X000 key then this one is all that is needed. The Toshibas generated multiple ranges for some odd reasons. That could be based on the wide range of Toshiba laptops with the afflicted problem.

54-71 (36h-47h in the EDID) byte is 0 based counting.

( 48,3f,40,f0,61,b0,32,40,40,80,6e,11,30,e4,10,00,00,19,... )

EDID BYTES:
0x   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
   ------------------------------------------------
00 | 00 FF FF FF FF FF FF 00 4C A3 55 32 00 00 00 00
10 | 00 0C 01 03 80 1E 17 78 0A AD 71 96 57 52 89 27
20 | 23 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
30 | 01 01 01 01 01 01 48 3F 40 F0 61 B0 32 40 40 80
40 | 6E 11 30 E4 10 00 00 19 00 00 00 0F 00 00 00 00
50 | 00 00 00 00 00 19 AF 02 32 00 00 00 00 FE 00 32
60 | 52 32 39 30 32 31 35 30 55 32 0A 20 00 00 00 FE
70 | 00 E2 B4 93 77 4E 2E 0F 00 02 0A 20 20 20 00 79

-- Updated --

If you decode an EDID you will see this range pertains to the resolution in particular. You could overwrite the whole EDID to match the SEC exactly by changing the 36,12 to 00,7F -- start at byte 0 and go for 127d bytes (7Fh). This leaves out the checksum which is calculated by the driver anyway.

Edited by Teraphy

Share this post


Link to post
Share on other sites
Bob the Dino

Thanks A LOT to everyone who helped.

I put the entire EDID into the INF this time, and it works perfectly, 1600x1200 is properly recogized and I can switch to it in the first game I tested (Sid Meier's Pirates!). My EDID is a little different from Darmdorf's, but this is the line I added.

HKR,, OverrideEdidFlags0, %REG_BINARY%, 
3A,C4,00,03,00,00,FF,FF,04,00,00,00,00,
7F,00,ff,ff,ff,ff,ff,ff,00,4c,a3,55,32,00,00,
00,00,00,0d,01,03,80,1e,17,78,0a,ad,75,
96,57,52,89,27,23,50,54,00,00,00,01,01,
01,01,01,01,01,01,01,01,01,01,01,01,01,
01,48,3f,40,30,62,b0,32,40,40,80,6e,11,
30,e4,10,00,00,19,00,00,00,0f,00,00,00,
00,00,00,00,00,00,19,af,02,32,00,00,00,
00,fe,00,4d,31,36,33,35,02,31,35,30,55,
32,0a,20,00,00,00,fe,00,e6,d6,c0,a9,8a,
67,43,00,02,0a,20,20,20,00,38

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...