Jump to content
LaptopVideo2Go Forums

Go5200 Slowdown upon installing SP2


Krupkaa2

Recommended Posts

Before I begin, thanks. The registration process was quite painless, and an excellent idea (in my opinion) to help you guys help me.

My hard drive, about a week ago, decided that it wasnt going to read large sections of itself. I pulled an emergency evacuate onto another drive, bought a new one, and began to install XP, my drivers, and all the Windows updates (Including SP2).

I took the time to also install HL2, HL1, and Rainbow 6-3.

Everything seemed fine untill I booted HL1. To my chagrin, it seemed to enter bullet-time every 3 seconds, for about 5 seconds, followed with a hint of normal speed. Repeat.

Obviously, you all know this system should be able to tear through HL1, but it doesn't. I did experience some success with using the software renderer (I had previously been using OpenGL or D3D, both with similar results), but even it had glimpses of the slowdown.

I tried running R6-3, and the problem was even worse there. It's as if I am playing Max Payne with permanent bullet time-- sounds play perfectly fine, but the animations, and my own movement, drag at what might be about half speed.

I called Dell, and they suggested I pay $50 to discuss the issue. I have no intent on doing that.

I tried installing the latest video drivers from Dell, I tried installing the suggested drivers from Microsoft update, I tried nuking all the drivers then repeating the above, to no avail. I tried rolling back drivers directly after SP2 install, with no effect.

I reformatted my drive and repeated all those other things, with absolutely no effect. The only thing that worked was not installing SP2, or pulling a system resore to before SP2 was on there. To be sure, I also installed DirectX 9.0c before I installed SP2, and the games worked fine.

I have narrowed the dirty culprit to be SP2. Mind you, it all worked fine before my drive died, SP2 and all. I don't know what to do, and I'm at my wits end. I've been playing Super Smash Bros. Melee at dangerous levels to fill the void of PC gaming.

Help me. Please.

P.S. One thing I forgot to mention-- over the summer I upgraded my card from a 32mb to a 64mb. I stayed in-model. Dunno if that would make a difference. The machine took the upgrade quite fine, I never needed to change anything.

Link to comment
Share on other sites

We have nearly identical machines and SP2 runs fine here. Try driver 67.66 with my nv4_disp.inf here and see if it helps. I've worked around many of the problems with the Dell drivers, and 67.66 has consistently been a good performer with the 5150.

Link to comment
Share on other sites

Tried that, with no success.

The wierd thing is that SP2 worked before my drive went nuts. I have absolutely no idea what is going on now.

Just to be sure, the install procedure went like this:

I installed the 67.66 drivers, then I went to my device manager and used have disk to install the *.inf. Reboot.

Any other advice? Maybe an OEM SP2 from Dell I should know about?

Link to comment
Share on other sites

I suspect you don't have the intel chipset drivers installed, so AGP isn't working correctly. (It's not part of XP or SP2.) Download both the "Dell Notebook System Software" and "Intel Mobile Chipset" from the Dell download page here.

Link to comment
Share on other sites

Should I install the processor driver too?

P.S. If it was the chipset drivers, it shouldn't work in either SP1 or SP2, right? Installing SP2 is the best correlation I have to it's failure.

Edit Later:

I installed the Chipset Update. No effect. I can't help but feel that last time, I didn't install the chipset, and let Windows do it all for me. Could that be it?

Thanks for you help, by the way; I really appreciate it.

Link to comment
Share on other sites

You shouldn't need the processor driver. SP2 comes with a newer version than the one on Dell's site. If SP2 continutes to be a problem and you decide to run without it, then yes, I'd definitely install it.

Normally I'd suspect the usual problems -- heat and so forth. But they all apply equally to SP1 and SP2. The SP2 part is puzzling, especially since so many of us 5150 users are running it.

Since the problem only happes when running games, it's probably a DirectX problem. How about playing DVDs. Can you play them smoothly, or are they also appearing slow and jerky?

Here's something you can try. Find the"PowerMizer" page in the nvidia control panel and set both sliders for Max Performance. Try the game again and see what happens. That will tell us if the nvidia card is slowing down for some reason. (You may need to reboot after changing the PowerMizer sliders.)

Link to comment
Share on other sites

I can play DVD's fine. I'm really not sure what to do at this point. Is there any way to completely uninstall my Chipset Drivers, and let Windows do it's own?

Or, I am wondering one thing. My system came with a 32mb Video Card. I upgraded to 64mb over the summer. I may be pushing it, but would I need to reinstall Windows with my 32mb to make it happy?

I see no reason why that would make any difference whatsoever, but I'm reaching the end of my options.

As for DirectX, I installed 9.0c before I got SP2 (It gets 9.0c for you when you update) just to see if it was DX and not SP2. It worked fine. I cant convince any other version to install over it, or allow me to nuke it, either.

Link to comment
Share on other sites

I doubt it's the problem, but it wouldn't hurt to try, if only to check out the possibility. If it was a hardware problem, it would show up in your pre-SP2 installation. If you want to check it out, you don't need to reinstall any software... Just swap the video cards and see what happens.

By the way, when you install SP2, I hope you check the option to save the backup files so you can easily uninstall it again.

One other thought: If you tried the PowerMizer experiment with no success, check the settings in the "Power Options" applet in the Windows Control Panel. Make sure you aren't in "Max Battery" mode or something like that. Use the "Portable/Laptop" profile, unless you want to lock your CPU at full speed. In that case use the "Home/Office Desk" profile.

And yet another thought: Make sure nothing else is running when you're trying your game. Maybe SP2 is trying to defrag or something.

Link to comment
Share on other sites

Really very strange.

I guess you have tried really nuking the drivers (which works best by uninstalling the drivers via "Add or remove programs") and reinstalling.

Can you go to the Advanced tab of Display Properties and check whether the NVIDIA-specific tab is there? If it isn't, something is wrong with the driver installation, or the card is not set to full hardware acceleration for some reason (see Troubleshooting Tab). In the NVIDIA panel you can check whether AGP is at the correct setting, fastwrites are enabled and so forth.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...