Jump to content
LaptopVideo2Go Forums

World of Warcraft performance


Guest alterhomme

Recommended Posts

Guest alterhomme

Hello,

I have a serious FPS problem with World of Warcraft, my average FPS is around 15 and the only time I get 30-40 is when im staring at the wall.

I'm running WoW on:

Toshiba Satellite p25-s670

Intel Pentium 3.2 w. HT

nVidia GeForce FX 5700 Go w. 128 Mb

1.5 Gb PC 2700 DDR RAM

Windows XP SP2

I tried to optimize performance by turning off the glow effect, by reducing the terrain draw distance, checking for viruses (i have none), cleaning up the drive, stripping XP of some useless services, defragging it, tweaking the UI more performance-like so i really have no idea whatsoever what to do now...

Oh and drivers - I followed the advice from the FAQ and installed 56.72 drivers with modified INF, i really have no choice actually, because if i install any other drivers i can't play video files in ANY player, be it windows meadia player or any other, i can hear sound but not the picture...

So if any of you guys help me out here I will GREATLY appreciate it, because I'm getting frustrated here already and seriously considering smashing my lappy in gizillion small pieces :)

Link to comment
Share on other sites

WOW has some performance issues, but in the ingame video options, things like texture complexity and some other things, like any type of shaders and other stuff should be turned off. (try different things)

I need to get a pic of the settings for it running on our old desktop PC (my brother plays it), and while the game still lags a bit, it is still playable for him.

You could also try setting the priority of the game to high in the task manager, or get a program that can do that for you, but tweaking options should make the game playable.

Also the 77.77 drivers or 80.40 drivers should run the game well, to get video playback you need to enable the VMR option in the control panel of the newer drivers (look in video overlay menu). (also might need to enable it in windows media player)

And while this might sound obvious, you might want to check to see if any resource hogging programs, or any programs whatsover, are running in the backround. This is once of those games where a backround program could really make it lag.

Edited by Bill
Link to comment
Share on other sites

Guest alterhomme

Hey, Bill, thanks a lot for your reply, but I have a question: how do I access thi svideo overlay menu? I mean I found it in the WMP optios, but I have no idea where it is in the driver control panel, and where the driver control panel is for that matter :)

Thanks in advance

Link to comment
Share on other sites

Right click on your desktop, go to display properties, click advanced, then when the menu with all the tabs comes up, click your card. (top right corner, or should be)

Next on the page on the right click on the video overlay settings menu, and the "enable VMR" option is in the bottem left corner.

If your screen flashes when you access the control panel and it bugs you, please refer to this topic to turn the overclocking page off. (unless you like to overclock)

http://forums.laptopvideo2go.com/index.php?showtopic=5786

Clicking on each of the options in that topic will change your overclock page setting for you, no need to open the windows registry editor or mod INFs.

Bill

Link to comment
Share on other sites

Guest alterhomme

I installed 80.40 and turned VMR on - video playback works now (thanks for this one, Bill), I ran 3DMark01 and got something like 10,900-11,100 marks over several attempts, pretty much the same as the 56.72.

I haven't had any significant improvement in the WoW performance though, so I tweaked some stuff like screen resolution - been running it at 1280x782 or so, changed it to 1280x720, FPS went up to almost 20 average.. maybe it was all about resolution after all, but I have a wide screen, and standard resolutions look real ugly, so I really have no choice in this matter

As for resource hogging stuff, other than Norton AV and Kaspersky Anti-Hacker I have pretty much only necessary system stuff in the processes, I don't think this is the problem

Anyways, I appreciate the help. Thanks a lot. If anyone else has anything to say on the matter, please do, I could use any piece of advice to get the max out of my system :)

Link to comment
Share on other sites

Some more advice would be to atleast turn of Norton while you are gaming, that can hog some resources I would bet.

Link to comment
Share on other sites

  • 3 weeks later...

I used to play the BETA with an old Pentium 4 1.8ghz (no hyperthreading) 386mb pc133 sdram and a GeForce 2 MX 32mb and it ran pretty smooth on pretty much the lowest settings, lol. I'd imagine your computer could handle it much better at better settings. Maybe you have to give up on some of the settings to get more fps?

Link to comment
Share on other sites

  • 2 months later...

Currenlty can't get the game to play anymore after the 1.9 patch on my Packard Bell Geforce4 440 64 meg Nvidia Card at all due to bluescreens Machine_Exception bullocks

Haven't been able to find a driver yet that copes / doesn't do this and I've been looking everywhere *sighs*

Only just started looking here though so fingers crossed something works or I'll have to close the account I guess.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...