Jump to content
LaptopVideo2Go Forums

Nvidia Drivers Help!


Guest Zara

Recommended Posts

Civilization 4 is out 3 days now in Germany. After I got it, I had to go through the troubles of finding the newest drivers for my laptop's graphics card (Under windows ist called: NVidia GeForce4 440 Go 64M.) Without them i could only play the tutotial and that with incorrect (black) displayed terrain.

My lapttop's distributer actually does not provide driver Updates, that's what they said after I called them about it. :angry:

Fortunately there are people in the Internet who do that for free. :)

I used the latest drivers from your page. The Graphics would fork than and i could play, but now the is an issue with the mouse. The mouse pointer freezes at the start of a new game or sometimes later, apparently random.

It seems I'm not the only one with this problem. (If you can read german, see here: http://www.civforum.de/showthread.php?t=27205 )

I can really use some help here. The Mouse drivers are not the issue here, i tested that enough and before the install of the latest graphics card drivers, that mouse worked.

I already tried to get back to the 2nd latest drivers, but that would help either. I have to say though, that i got an error message about missing files, but the graphis would wokr fine, just not the mouse.

I'm almost out of ideas what i could do here, so any hint would be useful. Thank you.

Link to comment
Share on other sites

Try going into the additional D3D settings page and set the max frames to render ahead to 1, or 0, might reduce lag or something.

Sorry I can't read German.

What mouse and what laptop do you have?

Also, whenever you downgrade drivers, you need to uninstall the newer ones first, otherwise windows might not boot up. (black or blue screen)

Link to comment
Share on other sites

I'm not an expert on this. For installation ist used the 'Actualize Driver' option unter the 'device manager' (if that's what they are called in english). Same for the downgrade. Obviously thats not the best way, although it made the graphics of the game work. Today is completly unstalled the drivers and the nvidia sotware and installed 87.87., with the modifed .inv i found when i searched these forums for "NVidia GeForce4 440 Go 64M". The game seems to work better now. I was actually able to play it though on a small map, without the mouse pointer freezing at all. Still got the bug on a standart size map, though.

While I'm waiting fot the first patch for civ4 that could probably fix this, I am still trying to solve it myself. My Graphics Card is, as far as I can tell, the NVidia GeForce4 440 Go 64M mentioned above. My Mouse is a Logitech Cordless Optical, part of an Itouch Keybord and Mouse Set. I also got a Synaptics Touch Pad, but I already disabled that one.

I'm gone try and reduce the frames rendered ahead under D3D, but I'm still thankful for any ideas.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...