Jump to content
LaptopVideo2Go Forums

Moniter doesn't turn on


Guest artgoon

Recommended Posts

Guest artgoon

Just recently I'm noticing display problems on my laptop. Sometimes during start-up, my display won't turn on. The computer seems to be running fine otherwise. It will only work after repeatingly rebooting the system several times.

Specs:

HP Pavilion zd7000

P4 3.2 GHz 512MB RAM

NVIDIA GeForce FX Go5700

I tried checking for updated drivers but apparently Nvidia discontinued the Go drivers. I'm a bit unsure what driver to grab off this site if it could fix the problem.

The only recent program I installed was the Half-life 2 game which mentioned that my drivers need updating. Would uninstalling it fix my problem?

Link to comment
Share on other sites

Same problem, see my topic! Didn't see yours before I started mine.

Something's not right here!

[edit] what version of the driver do you have? Does a CRT work? S-Video? I finally got mine to turn on again but I don't want to turn it off for fear that it might break again ... I downgraded it to 77.79 (latest MCE drivers) with a CRT plugged in ... I don't know about this, it's all really not good... I hope it's not just coincidence that we have the same problems...

Link to comment
Share on other sites

Guest artgoon
Same problem, see my topic! Didn't see yours before I started mine.

Something's not right here!

[edit] what version of the driver do you have? Does a CRT work? S-Video? I finally got mine to turn on again but I don't want to turn it off for fear that it might break again ... I downgraded it to 77.79 (latest MCE drivers) with a CRT plugged in ... I don't know about this, it's all really not good... I hope it's not just coincidence that we have the same problems...

Beats me. I actually found a few other cases of this in this forum and in the zd7000 forum but couldn't find a permanent solution. I'm not even sure if it's a driver issue. I was thinking about hooking up a moniter to this baby to see because it might be hardware. I have the default drivers that came with it...Not sure the version.

I'm a complete intermediate user so if anyone has a solution...

Edited by artgoon
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...