Jump to content
LaptopVideo2Go Forums

non working nvidia fx5700go


maxrlx

Recommended Posts

Hi everybody, i have a toshiba satellite p25 s670, media center edition, with a nvidia fx 5700go, wich stoped working when i was playing vampire the masquerade bloodlines. i reinstalled the drivers, formated the computer using the recovery disc, but the screen is all black. i had to install win xp professional without the graphic drivers(with the drivers installed i get a black screen) in order to use the laptop, now i dont have any graphic acceleration, and the resolution is limited to 1024x768. Any help is welcome. Thanks in advance.

Link to comment
Share on other sites

It sounds to me like it could be a bad motherboard or possible video card. You should try reinstalling the drivers Toshiba provided. You might want to email toshiba and see if they have a solution. Also, check out this forum that discusses the problems people have had with Toshiba laptops.

Link to comment
Share on other sites

thanks, but if its a bad motherboard or graphic card can it be fixed?, and if i have to buy new how much would it probably cost?

Link to comment
Share on other sites

It can be fixed, but it would have to be shipped to Toshiba. I would give them a call and see what they recommend. When I had to ship my notebook back to HP to replace a cracked LCD screen, I removed my battery and hard drive so they wouldn't reformat my HD. The cost... hmmm... When I replaced my LCD screen, which wasn't covered under warrenty, costed me $700 USD. Thankfully I had a credit card. Is your laptop still under warrenty?

Link to comment
Share on other sites

  • 1 year later...
Guest mrgraphicgb
Hi everybody, i have a toshiba satellite p25 s670, media center edition, with a nvidia fx 5700go, wich stoped working when i was playing vampire the masquerade bloodlines. i reinstalled the drivers, formated the computer using the recovery disc, but the screen is all black. i had to install win xp professional without the graphic drivers(with the drivers installed i get a black screen) in order to use the laptop, now i dont have any graphic acceleration, and the resolution is limited to 1024x768. Any help is welcome. Thanks in advance.

yOR 5200 vIDEO CHIP CAME LOOSE FROM THE BOARD. Trash it, made in china and out of production by Sub-Contractor to Toshiba. You will look for a motherboard forever and just find another with the same eventual problem. That model was destin to die! :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...