Jump to content
LaptopVideo2Go Forums

AirgoNet true MIMO drivers


Recommended Posts

Here is a driver and Client Utility for the Airgo range of Wifi PC-Cards and PCI cards.

I've made this driver from various OEM's.

The driver versions are the latest that I know of, let me know if you know of newer.

The INF is setup for PC-Cards but will work with PCI cards as well, athough a forced install might be needed.

The Client Utility is from ASUS as this is the best for the Pre-N cards by far

This will work for all the OEM cards out there (does for my Belkin Pre-N card)

Uninstall old Client Utility should you wish to use the included Netgear one.

If you just want the updated driver and keep the current Client Ultility then just point the Update drivers to the driver dir with the INF in it.

Run the 'Autorun' file in the root dir, should the driver not be updated, you will need to do this manually with 'Update drivers'

The driver also includes the very latest security (AegisI5) files so you can enjoy WPA2 and all it's lower sibblings.

I've enabled all receive and transmit antenna's and set compression to auto.

Works on:

Belkin F5D8010

Linksys WPC511GX

Netgear WGM511

Buffalo WLI-CB-G108

Buffalo WLI-CB-AG108HP

AeroGuard AGN1023PC

Planex CQW-NS108AG

Planex CQW-NS108G

Samsung X20 Laptop

GemTek WPCO-131G

Corega CG-WLCB108GM

Pre-N Driver v1.5.5.1

ASUS Client Utility

AegisI5 v3.4.10.0

AirgoNet ASUS based Client Utility

AirgoNet Pre-N driver v1.5.5.1

AirgoNet Pre-N driver v1.5.5.6

Feedback encouraged.

Link to comment
Share on other sites

  • 2 weeks later...

Changed to ASUS Client utility much better.

Changed the driver names to fool the ASUS installer to think another card is installed.

Now you have full control over WIFI functions, and proper WZC is properly disabled with the Utility.

Included latest driver, Security files and latest Cliet Utility from various OEMs to make this.

Just unistall old Client utility and drivers and run setup with this one.

The card will be shown as a ASUS 240Mbps Airgo, this is needed to fool the Utility so no worries here.


let me know of later driver, or utility exist, I can update the files easily now.

Link to comment
Share on other sites

Pieter, i have seen a few GemTek WLAN drivers in the past while browsing through OEM download archives. Are you in need of those (links?) in the future?

Link to comment
Share on other sites

That would be good :) , as you can see above I don't have a link for the Gemtek version of this Wifi card.

Most OEM's use the AirgoNet Client Utility, but may have later version drivers lurking around :)

Link to comment
Share on other sites

Found the release again (the one i was speaking of). Will upload tommorow as the file is on my PC at work. Also found another release today, which i uploaded HERE Don't know if it's old or new or if you really need it. You/i can delete it if you have downloaded it.

I forgot exactly where they origin from: either it is Gericom, Zepto, Alienware, ECS or Arima.

Link to comment
Share on other sites

Completely remade the driver, not happy with one before.

Installer works in english now (should als work in other languages)

Still have a niggly problem with the wifi center when you run the cursor over it the language is wrong.

Not quite sure how to fix this, but everything works all the same.

Link to comment
Share on other sites

Ah finally the ones I've been waiting on :)

I'll go and have play now.

Link to comment
Share on other sites

A bit dissapointing, the Client utility is just the plain jane Airgo one :)

And the driver is old.

Nevermind, I'll keep working on the ASUS one.

Link to comment
Share on other sites

  • 2 weeks later...
Guest Jeremy

I was able to install the airgo driver for my pre-n belkin card to get WPA2 capability, though it is dated June 30, 2005, Seems to be working great, though I always have a "Very good" signal strength, not Excellent. Is there a more recent Driver available that I am unware of. Any help would be greatly appreciated.

Link to comment
Share on other sites

Guest Jeremy

I would love to Install the Airgonet Pre-N driver with Asus Client 2917.... but it seems the file has been removed from the site? Could it be posted again...Hopefully this will boost my signal strength just a bit more? Any help would be great...


Link to comment
Share on other sites

File size is zero :) uploading again.

I also cannot get excellent on my signal strength. (only has this for a few seconds).

This matters little as long as you get full speed at distance.

I'm only testing this on a 54Mbps wifi-router.

In my house I can get full speed at the far end of the house through 2 walls (about 20m away)

I could most certainly not get this with my Dlink Airplus G650+ card where I'd be on about 24Mbps.

The Belkn card is excellent for range boost, I hope to get either a Airplus based 240Mbps or Pre-n Wifi-router soon

I'm still trialing the Client Utility having some problems with Center.exe had to revert back to v2896.

I have incuded the latest driver version v1.5.5.1

Also includes latest Aegis files need for non WZC client apps

When installing it's best to run the setup and install the Client utility.

BEFORE rebooting, manualy up date the drivers, point the update drivers to:

\program files\ASUS\WLAN card utilies\Driver\

Now reboot and let the ASUS setup app turn off WZC

If your unsure on all this it may pay to just leave this, as it can be tricky to work with.

This is a work in progress

Link to comment
Share on other sites

Guest Jeremy

Thanks for the clarification on the signal strength.

I was able to download the file successfully after your re-upload.

I unzipped the file and then ran the setup.

After it installed, I installed the drivers from ASUS/WLAN... folder in program files to the card.

Then I restarted

Upon reboot, I ran the client manager and it asked if I would like it or WZC to control the WLAN.

I chose the Asus Client Manager

It wouldn't recognize that I had a WLAN card in the PCMCIA slot.

I checked the driver # on the card and it says I have from 1/17/06, but your previous posts say the file should be

The client manager couldn't recognize my card.

Is there a step I am missing?

Thanks for your help.


Link to comment
Share on other sites

Bugger and curse's my sneaky driver replacement is not working as it should.

Even though I thought I had replaced the original drivers (240mbps Airgo) it still finds them some how and places these in the ASUS dir.

The CAB files are very hard to work with and require a special file and lots of fiddly work.

I'll do some more work on this.

Link to comment
Share on other sites

Right, in the mean time head back to the 1st post and grab the seperate driver files I've uploaded.

Update the Airgonet driver that are in the system properties to the ones I've just uploaded (v1.5.5.1)

Once done the ASUS Client utility should then become active.

You may need to uninstall it and then reinstall it, but after you install and before the reboot install the newly uploaded drivers.

Then on reboot turn off WZC as asked then a wifi connect wizard will start (the ASUS one) all going well you'll have a fully usable Client utility.

The ASUS one is by far the best (I've tried them all), but it does mean all this fiddleing about to get it started.

The ASUS Client utility looks for certain registry enteries that is why the driver files are renamed to what they are and the INF is from the 240mbps Aigonet card as they INF setting are the same for both cards.

v2917 of the Client utility has one little bug with the tray icon when placing the cursor over it the text it displays is all goobledy gook, going back to v2896 only for center.exe fixes this.

Not sure why this is.

But I'll slowly get this all sorted.

Link to comment
Share on other sites

Guest Jeremy

Well, I installed the ASUS Client from the file airgonet_2917. After Install, I installed the drivers from file you recently uploaded. Then, Rebooted. After reboot, ran ASUS program, which asked if it or WZC should control wifi controllers. Chose ASUS program. THen it said they couldn't find a WLAN card (even though it was plugged in to my PCMCIA Slot).

Upon checking the Driver files, it can find the number or date of it.

the driver seems to be very stable while using WZC client from Windows, so I guess I will probably just stuck with this for now...

I appreciate you help...I wish Airgo made their drivers a bit more accesible (this is the only web page I could find the driver. Saved my life...

Thanks a ton

Link to comment
Share on other sites

The driver is not installing properly by the looks of it.

I have a feeling your original driver is being installed.

The ASUS Client utility needs to be fooled into thinking an ASUS card is plugged in.

Extract the drivers somewhere you can find them (v1.5.5.1)

You need to go to 'System' Properties in the control panel (or rightclick on 'My Computer then properties)

Then 'Hardware'

Then 'Device Manager'

Then select 'Network adaptors'

In here should be your PC_card, not sure what name it's called.

Now double click this.

Then "driver' tab

Then 'update driver'

Now in the 'Welcome to Hardware update wizard' (XP with SP2) select 'No, not this time'

Now select 'Install from a list or specific location'

Now select 'Don't search I'll select driver to install'

Now select 'Have disk'

Now browse to where the drivers were extracted.

Select tmimo3p.inf (only INF that should show in the dir)


Now select either choice (this is to fool the ASUS client utility into thinking that model is installed)

You'll now get a 'Update Driver warning' click yes

Now you'll get a warning to say that the driver is not WHQL, click 'Continue anyway'

Driver will install.

When done there should be 2 lights on the PC-Card.

If you installed the ASUS utility it should now come on.

The above will work should you want to try the ASUS Client utility or just want to have the latest drivers and use WZC to control everything (I hate not having the 'scan feature so I stay away from WZC)

If your original drivers are still installed, ie it still says Belkin in the system properties, try uninstalling the drivers then reboot when new Hardware found point it to the INF mentioned above and it will install the latest version.

Also make sure the Belkin Client utility is uninstalled as both cannot operate at once.

I hope this helps.

Keep an eye on this thread as I'll update the driver or Client utility or Aegis files as soon as I find newer ones.

Link to comment
Share on other sites

Guest Jeremy


I got the drivers to work. I wasn't uninstalling the older airgo drivers first...

however, I have been unable to get the Asus utility to acknowledge my WLAN card.

in the installation process, as you described...it gets to the point where I have browsed to find the drivers (after the installation of the ASUS utility), and I instal the tmimo3p.inf file (the only one in the dir). When I do this, you say I should have a choice, but I don't...it is only one thing...Airgo True Mimo Driver (nothing about asus). Is there something else I need to be doing to trick the program?

From what I can tell, I am sure I will like this asus, if I can ever get it working.

Link to comment
Share on other sites

Ah, I see, all fixed (download driver again), also went through and enabled all the settings in the system control panel.

You can now fiddle with all the settings under the sun that Airgo have for their cards.

This is now guaranteed or your money back :)

It is all very fiddely, but in the end worth it for me.

I like the ASUS CU as I can flick between differnent wifi routers really easily, and has the most features to play with.

Hopefully this has it sorted for you.

I'll remake the actual Control Utility file sometime with the driver included seperately.

Good to have a beta tester to try things on :)

Link to comment
Share on other sites

Guest Jeremy


I am proud to say that I am writing to you with a connection of the drivers and the ASUS Client working.

Everything is running smoothly, and I like the added benefits of the ASUS Client, especially seeing the channel, and scanning and automatically connecting to the strongest signal.

One thing, I am running WPA2/AES encryption on my network, and when I 'scan' for available networks with the asus client, it shows my network as WEP encrypted, but when I specify my SSID and passkey (With WPA2), I connect to it fine, even though my SSID must be broadcasting a WEP encryption. One other network in range shows WPA/TKIP, but none show WPA2 as they do with WZC.

All in all thats pretty minor..just wanted to point it out. Thanks for helping me out...I am glad that I have WPA2 encryption now (I cannot believe Belkin doens't directly support it).

I am running Pre-n Router and Pre-n Card and get a Very good signal at 108 all the time. I haven't tested the range yet, but I am sure I can walk to the end of the street and still be connected rather strongly.

I originally bought the router because of its range, ease of use and reliability (compared to the standard Linksys in use today by so many people that have problems). However, I noticed my mini-pci card (Intel 2200BG) was constantly losing connection speed dropping from 54mbs to 24mbs and just sitting there. After reading tons of forums, I realized that more than likely, my wireless card was just inferior and couldn't handle the data the router was putting out. Installing the Wireless card stabilized the network. The other cards using the network (later intel cards) don't seem to have a problem with the Belkin router.

Now I can connect at 108mbs all the time and have the wpa2 capability. Thanks so much!!

Link to comment
Share on other sites

Good to hear of your success :)

When I scan it shows my Router a Belkin F5D7230-4P that I'm connected AES/WPA_PSK as I've setup on the router.

Your router must be on WEP as my Pre-N card can also pick up the neighbours router (down a hill and across the road), this shows WEP connection as he's set up with this.

I also had a a play with a WRT54GS and this was also correctly shown.

Yes the Belkin software leaves a lot to be desired, it's ancient and WPA (2) wasn't even around when the Client utility was included (18months ago)

I will doubt that there will be a later driver update (unless Argonet do a proper Vista one)

Speaking of Vista the driver works with Vista.

The belkin Pre-N router is supposed to be the better of the 3 big brands (linksys and Netgear) it has the highest throughput.

I'm trying to get hold of a A/B/G version of this Pre-N card, Buffalo and Planex make one, trying to get one is not so easy.

Will also probably get a Pre-N or Draft-N router (Airgonet based) to get the speed up.

Now if you want a mini-PCI card version of the Pre-N the LG X20 comes with one.

You'll need to keep an eye on ebay for one, then you'll have the best.

Without a doubt the Aigonet based Pre-N is probably the best Wifi out there at the moment, even the 300Mbps cards drop off in speed quite quick to be not all that much faster at distance.

Link to comment
Share on other sites

Guest Jeremy

I went into my router settings and everything is set up WPA2/AES (I have never used WEP on my router), and I a connected using WPA2 on the ASUS client, but the broadcast is still saying my network is WEP. Doesn't really matter I guess...As long as I am using WPA2, I don't care what the broadcast is saying.

I will definitely have to keep my eyes open for the LG x20 as you said, but I am very happy with the set up right now. I will be curious to see what 802.11n has to offer, but I know once it is released, it will have its own bugs to work out, so I know this pre-n will keep me happy for sometime...

Thanks for your help, and I will keep checking this thread occasionally to see any news.

Thanks again!

Link to comment
Share on other sites

Guest Jeremy

I was doing a little research, and I see the Samsung (X20) has released a computer with an airgo based chipset with MIMO technology, but I cannot find out if that mini-pci is for individual sale somewhere else. I am at no place to actually purchase this mini-pci right now, but I am just thinking for the future...Any thoughts?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...