Jump to content
LaptopVideo2Go Forums
Raziology

Geforce 8700M GT/Windows 7 x64 Ultimate

Recommended Posts

Raziology

Hi everyone

I have a Toshiba x200-15k that comes equipped with an Nvidia Geforce 8700M GT. The whole laptop is great, but ever since I switched to windows 7 Ultimate X64, I have started to encounter some problems on my desktop: The screen produces some flickers for a second every around 1 minute. I have realized that this mostly happens when I try to switch between different windows on my deskptop, or when I play a video file. I didn't have this problem when I had Windows 7 Ultimate X86 version 7077. I started to have the problem when I switched to windows 7 Ultimate x64 version 7100. I have tried countless Nvidia drivers WHQL certified, and around 10 different version of your modded .inf drivers, with uninstalling the drivers and then installing differents ones again, but the problem persisted. Then,through the windows 7 update menu, I have chosen to install the Nvidia WDDM 1.1 prerelease, and my problem was solved!Then I formatted my system and installed Windows 7 Ultimate X64 RTM ( version 7600), thinking that this might solve the problem and that I could at least use a display driver that would give me a better performance in games, knowing that the WDDM 1.1 version didn't give me the peformance that I wanted, and here I am stuck with the same problem: None of the display drivers, even the modded .inf ones didn't fix it for me, and worst of all, the WDDM 1.1 isn't available in the update menu for windows 7 RTM anymore.

May I point that my laptop screen operates at 59 HZ, which is something that's not common as most LCD laptop displays nowadays use 60 HZ.

Does anyone have this same problem I'm having? Does anyone know what I might do to fix it?

P.S: I have another windows installed on my laptop too ( Windows Vista x86 SP1), and it's functionining properly without any screen flickers.

Share this post


Link to post
Share on other sites
Raziology

hey =)

i also have a satellite x200 =)

for vista and windows 7 x64 use this driver:

http://rapidshare.com/files/213786718/Vista64_182.46.exe

it will works without any flixs :)

Thanks a lot for the reply man, but could you give me a link for the same driver other than on rapidshare? My ISP has blocked the website..

Thanks so much in advance :)

Share this post


Link to post
Share on other sites
Clemi

Thanks a lot for the reply man, but could you give me a link for the same driver other than on rapidshare? My ISP has blocked the website..

Thanks so much in advance :)

ok here you have :

i hope that it will works on your satellite too :)

Share this post


Link to post
Share on other sites
Raziology

ok here you have :

i hope that it will works on your satellite too :)

Oh thanks a ton man, it worked PERFECTLY.

My only complain however is that whenever I try to switch from one window to another using the windows key on the keyboard + TAB ( The 3D view of the windows), it's not smooth at all.

This has been the case with almost all of the Nvidia drivers that I have downloaded, but when I used the Toshiba drivers, they worked flawlessly. Even the WDDM 1.1 driver provided by microsoft update gave me a very smooth 3D view of the windows. Although the driver you've given me fixed my flickering problem, but still, I would like to know how would I get the smooth "FEEL" when I 3D view my desktop.

Again thanks a lot for your help :)

Share this post


Link to post
Share on other sites
Spax87

this flickering is a bug that only happens with 8700m gt.

got it too. it appears with 185.xx and higher driver-versions.

i hope it get fixed soon, cause i dont wanna stay on 182.46 forever^^

Share this post


Link to post
Share on other sites
Raziology

this flickering is a bug that only happens with 8700m gt.

got it too. it appears with 185.xx and higher driver-versions.

i hope it get fixed soon, cause i dont wanna stay on 182.46 forever^^

Well man, I'm starting to doubt that this is something that's related to our SCREEN, 'cause I haven't heard anyone complain about their Geforce 8700m GT but people with the x200 series!

Share this post


Link to post
Share on other sites
Spax87

yeah, maybe its only on satego/satellite...

annoying...

Share this post


Link to post
Share on other sites
Raziology

It's pretty much annoying YES! especially that there are some new drivers that give a lot better performance than the drivers that we're stuck with right now.

Is there any way that we can escalate this problem to someone who might help us? Contact Nvidia for example?

Share this post


Link to post
Share on other sites
mum1989

works great no flickering, because I've a blackscreen on startup ! :)

So, I return to 182.05

(I've got a Toshiba Sattelite X200-21E (with 8700mgt 512mo GDDR3)

I've Seven Ultimate 64bit (RTM)

Share this post


Link to post
Share on other sites
opas50

I have the same flickering problem too with my x200. The problem is with the powermizer.

The flickering appears when the gpu and memory clock change.

Share this post


Link to post
Share on other sites
Spax87

sometimes it gets better when turning off powermizer.

but its still there.

its time that this bug gets fixed!!! :)

Edited by Spax87

Share this post


Link to post
Share on other sites
Raziology

Well shouldn't we be reporting the problem to Toshiba somehow?

I haven't heard anyone complain other than US ( the proud owners of x200 laptops)..

Or maybe we can contact Nvidia for this...

Share this post


Link to post
Share on other sites
Spax87

i also thought about that.

should we write an e-mail to nvidia???

:)

i dont wanna buy a new laptop cause the drivers dont work anymore.

i love my x200:)

Edited by Spax87

Share this post


Link to post
Share on other sites
Raziology

Well man, I have just downloaded a tool called NV GPU PRO. I have disabled PowerMizer through it. I only disabled PowerMizer when my laptop is plugged in ( using AC Adapter).

The result:

Windows AERO feels smoother, and the Windows Aero 3d Flip ( windows key + tab) no longer lags, and it's smooth as hell!

I'm using Driver version 186.03 which used to flicked A LOT, but so far, I've been working on my laptop for around 20 minutes now, and it has only flickered once when windows was still starting up. Try it on your laptop I hope it helps :)

This is the link http://forums.bit-tech.net/showthread.php?t=166494

Please let us know if it works for you too :)

Share this post


Link to post
Share on other sites
opas50

Disabling powermizer will increase the gpu temperature .

Share this post


Link to post
Share on other sites
Spax87

yeah, but thats no solution...

drivers need to be fixed. maybe just the infs. i dont know. but with diasabled powermizer the flickering is still there

Share this post


Link to post
Share on other sites
Raziology

I don't know man, I haven't had any flickers on my laptop since I disabled the powerMizer on AC Adapter ! Not only that, my 3d Flip which wasn't smooth AT ALL, is now SUPER SMOOTH as it was with the WDDM 1.1 drivers !

Share this post


Link to post
Share on other sites
Spax87

hm, tried to download gpu pro and got several virus alerts :)

Share this post


Link to post
Share on other sites
Raziology

Eset didn't detect anything at all. Executable files are scanned automatically whenever I download them, so I don't think that it has any viruses. It's worth trying it man trust me.

Share this post


Link to post
Share on other sites
Spax87

cant install it. my anti-virus deletes it as soon as its downloaded.

do you have another mirror?

Share this post


Link to post
Share on other sites
zipper

hm, tried to download gpu pro and got several virus alerts :)

Get a decent antivirus protection...

Share this post


Link to post
Share on other sites
Spax87

Get a decent antivirus protection...

for example?

Edited by Spax87

Share this post


Link to post
Share on other sites
Raziology

Eset Smart Security ! it doesn't suck up your computer resources and best of all, it detects almost all threats.

Share this post


Link to post
Share on other sites
zipper

I'm using what I can get free - ATM F-Secure IS 2010 with 3 months free license probably prolongable for 12 months. But it's not so light. I think you can find free Kaspersky, too.

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...