Jump to content
LaptopVideo2Go Forums
mobilenvidia

Latest Realtek Audio Codecs

Recommended Posts

erp-ster7n
On 6/10/2019 at 7:18 PM, aqdongo said:

 

FYI you can still download all the drivers from here (I have saved all the files in anticipating of something like this happening)

 

https://consumer.huawei.com/en/support/laptops/matebook-d-14-amd/

If you can't access it you can DL from the link below.

https://www.mediafire.com/file/sq9cdwx77dpzcab/MateBook_D_14_AMD_Audio_6.0.1.8459.zip

 

thanks aqdongo.  though I have recently edited my previous post to mention a customized 8708 UAD Dolby Huawei driver that has the newer UAD drivers plus the updated Dolby UWP components.

 

On 6/12/2019 at 12:52 AM, bdyekita said:

Hello everyone, since some days i just lost system sounds in windows 10 but all other sounds works fine. i have searched a lot at Google but non of those fixes worked, many times Uninstall and installed , ... what is problem with system sounds i don't get it! 

PLease help to fix it because non of notification works!!!

Windows 10 version 1903 build 18362.175 

Audio Driver Version is 8703.1 from  108.05 kB · 0 downloads stasio FF0CCapture.thumb.JPG.b3743380011cd3fd5d68545144a5925a.JPG

I think you might be using the wrong FFxx HDA driver, bdyekita.

In your screenshot, it seems hardware ID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0668&SUBSYS_102805AA" is mentioned in the HDXSGAW.inf file (I checked this hardware ID on the driver pack solution site drp.su).   Since that INF file mentions something about Maxxaudio, you should be using 8703.1 FF06 HDA driver, not the FF0C version.

try uninstalling the FF0C realtek driver, reboot and then obtain & install the FF06 version

also the recent Win10 updates screw up the system sound sometimes.  since you have Win10 v1903, see if you can revert or downgrade to v1809 - I don't have problems with system sounds on 1809

 

Share this post


Link to post
Share on other sites
bdyekita
20 minutes ago, erp-ster7n said:

thanks aqdongo.  though I have recently edited my previous post to mention a customized 8708 UAD Dolby Huawei driver that has the newer UAD drivers plus the updated Dolby UWP components.

 

I think you might be using the wrong FFxx HDA driver, bdyekita.

In your screenshot, it seems hardware ID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0668&SUBSYS_102805AA" is mentioned in the HDXSGAW.inf file (I checked this hardware ID on the driver pack solution site drp.su).   Since that INF file mentions something about Maxxaudio, you should be using 8703.1 FF06 HDA driver, not the FF0C version.

try uninstalling the FF0C realtek driver, reboot and then obtain & install the FF06 version

also the recent Win10 updates screw up the system sound sometimes.  since you have Win10 v1903, see if you can revert or downgrade to v1809 - I don't have problems with system sounds on 1809

 

a lot thanks for replay, I'm busy now with exams, but i will test as you guide me and will let you know, again thanks

Share this post


Link to post
Share on other sites
erp-ster7n

I have a custom built PC with a Gigabyte GA-78LMT-USB3-R2 motherboard using Realtek audio driver 8721.1 UAD Gigaybte version and running Win10 v1903 build 18362.145 (did not update to .175 build yet) and a few times some of the Windows System sounds do not play at all or play "partially" (like the "Notification" sound when I connect a usb device & autoplay is enabled) - only a minor problem I was encountering with Win10 v1903.

since I installed the 1903 version on top of the 1803 version on that PC, I will go back to 1803 and then update to Win10 v1809 since there are still a few other issues/problems with the 1903 version, including the recent KB4503293 update (build 18362.175) that causes the Event Viewer app to crash when using Custom Views.  maybe in mid-summer around late July or August the 1903 version of Win10 will be more stable and may have the system sound problem fixed by then

Share this post


Link to post
Share on other sites
jvidal

run sfc /scannow to check for missing/damaged system files

Share this post


Link to post
Share on other sites
DmiTrah
On 6/8/2019 at 7:29 PM, erp-ster7n said:

I have repacked the 8716.1 and 8721.1 generic UAD audio drivers so that the bundled Realtek setup program will automatically install or update the UAD drivers & Realtek components.

 

Hey . Can you also do 6.0.8726.1? or for xiaomi mi notebook pro 15.6. thanks

Share this post


Link to post
Share on other sites
Romagnolo1973
On 6/10/2019 at 5:44 PM, erp-ster7n said:

 

Huawei is using Universal Audio Drivers (UAD) with 2018 model Matebook laptop PCs starting with yours (w/ AMD Ryzen & newer)

there's another 8708.1 UAD driver (wright_kelvin_setup) package from Github that does have the Realtek setup.exe program instead of the InstallPackage.bat file.

However, both of those 8708 drivers do not include the Dolby Atmos component files found here (and does not include instructions on how to install or update the Dolby Atmos Software component for the Realtek UAD drivers):

https://github.com/alanfox2000/realtek-universal-audio-driver/tree/master/ThirdParty/Dolby/ext_realtek_huawei

 

I could create a customized 8708 or 8721 UAD driver pack that will include the Dolby Atmos UAD/UWP software for your Huawei laptop

edit: I no longer have access to the original 8459 Realtek UAD driver from the Huawei web site since my country (USA) has recently banned Huawei

Edit 2 (6/13) - here's the 8708 UAD + Dolby Huawei driver I recently made.  Requires uninstalling previous HDA/UAD drivers using Display Driver Uninstaller [DDU] and installing this new driver from scratch (aka "clean install").

Thank for your effort I realy apreciate it, thanks a lot.

Sadly your driver is not installing even from scratch, 

2019-06-17-223836.png

message said: in this package driver it was not supported any driver and refuse finishing the installation.

Issue is on wright_kelvin driver because i try it and the error message is the same appearing in your package

 

 

Thanks again, probably the only way is waiting Huawei update mine sound card driver + dolby and put it on huwei site to grab it and install.

 

Edited by Romagnolo1973

Share this post


Link to post
Share on other sites
stasio

Realtek HD Audio Driver 6.0.8734.1 WHQL

8734_FF00_FF04

Win 10 (RS5,19H1) x32/64
PackageVersion = PG473
DriverVer= 06/18/2019, 6.0.8734.1

Share this post


Link to post
Share on other sites
erp-ster7n
On 6/18/2019 at 7:53 AM, Romagnolo1973 said:

Thank for your effort I realy apreciate it, thanks a lot.

Sadly your driver is not installing even from scratch, 

2019-06-17-223836.png

message said: in this package driver it was not supported any driver and refuse finishing the installation.

Issue is on wright_kelvin driver because i try it and the error message is the same appearing in your package

 

 

Thanks again, probably the only way is waiting Huawei update mine sound card driver + dolby and put it on huwei site to grab it and install.

 

I found the problem, Romagnolo1973.  HWID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0256&SUBSYS_19E53206" not included in the HDXSSTHuawei.inf file of the 8708.1 UAD driver - that's why the install fails; I needed the other INF file "HDXHuawei.inf" which has it.

Edit 6/21: try this 8721 uad huawei dolby driver pack I recently made as I have removed the 8708 uad huawei driver pack.

I'd been very busy lately rebuilding/re-installing older Win10 versions (like either 1803 or 1809) some of my PCs - the 1903 version is not quite fully ready on my old PCs, even though MS silently released 1903 refresh ESDs since the 1903 media creation tool is recently downloading build 18362.175 instead of 18362.30

15 hours ago, stasio said:

Realtek HD Audio Driver 6.0.8734.1 WHQL

8734_FF00_FF04

Win 10 (RS5,19H1) x32/64
PackageVersion = PG473
DriverVer= 06/18/2019, 6.0.8734.1

any chance of realtek making newer FF03 & FF10 HDA drivers, stasio?

I'm still using 8703 FF10 on my relative's Dell Inspiron 580 desktop PC since that is the latest FF10 version so far

Share this post


Link to post
Share on other sites
stasio

^

FF03 & FF10 HDA are both on latest 8703.1 WHQL and FF03_8716.1 / FF10_8712.1 Beta.

Not sure what Realtek planning in future, but hope will get update soon.

Share this post


Link to post
Share on other sites
Romagnolo1973
20 hours ago, erp-ster7n said:

I found the problem, Romagnolo1973.  HWID "HDAUDIO\FUNC_01&VEN_10EC&DEV_0256&SUBSYS_19E53206" not included in the HDXSSTHuawei.inf file of the 8708.1 UAD driver - that's why the install fails; I needed the other INF file "HDXHuawei.inf" which has it.

Edit 6/21: try this 8721 uad huawei dolby driver pack I recently made as I have removed the 8708 uad huawei driver pack.

I'd been very busy lately rebuilding/re-installing older Win10 versions (like either 1803 or 1809) some of my PCs - the 1903 version is not quite fully ready on my old PCs, even though MS silently released 1903 refresh ESDs since the 1903 media creation tool is recently downloading build 18362.175 instead of 18362.30

 

Thanks you are a kind person that help us  so much spending your time for solving mine/our issue

I try your new driver and Realtek part is OK: Audio working, microphones working, reallek audio console is working too, perfect 100%

The only issue remaining is with the Dolby part: is not installed at all. I have uninstalled older driver using DDU in safe mode. DDU uninstall Realtek but does nothing with dolby, installed your pack oldest Doby sound system app said is not working so I have tried even uninstalling Dolby app from the system with RevoUninstaller and reinstall your pack but Dolby still continue not been installed and  is not present on the system.  

 

OffTopic: I have an older Lenovo laptop that lenovo abandoned soon on win7, I found some trick to install win8 and win10 too and  last 1903is working perfectly, but Linux (manjaro in my case) is a better option for this kind of older pcs

Share this post


Link to post
Share on other sites
erp-ster7n

somehow the Realtek setup program did not install the Dolby components from the dax3_ext_rtk_dolbyatmossoundsystem.inf file from the \Win64\Thirdparty\Dolby\ext_realtek_huawei\ext_huawei_kepler_rs4_rs5_19h1_v233\ folder.  check in Device Manager (devmgmt.msc) in the Software Components section if any Dolby software components are listed [if not, they might have to be installed manually with either pnputil.exe or Driverstore explorer (rapr.exe)]

also DisplayDriver Uninstaller (DDU) does NOT remove/uninstall the existing Dolby software components.  you have to use DriverStore Explorer [rapr.exe] to do that - remove anything Dolby related with the DriverStore Explorer app before installing the newer version with either pnputil.exe or DriverStore Explorer (rapr.exe).

---

unrelated note: Microsoft was very late in posting a Realtek UAD driver from May 2019 - 8699.1 (5/7/2019) on the Catalog site, MS posted this 6/24

https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.8699.1

(no Realtek UAD drivers in MS Catalog in the 8700s...yet)

Share this post


Link to post
Share on other sites
Romagnolo1973
2 hours ago, erp-ster7n said:

somehow the Realtek setup program did not install the Dolby components from the dax3_ext_rtk_dolbyatmossoundsystem.inf file from the \Win64\Thirdparty\Dolby\ext_realtek_huawei\ext_huawei_kepler_rs4_rs5_19h1_v233\ folder.  check in Device Manager (devmgmt.msc) in the Software Components section if any Dolby software components are listed [if not, they might have to be installed manually with either pnputil.exe or Driverstore explorer (rapr.exe)]

also DisplayDriver Uninstaller (DDU) does NOT remove/uninstall the existing Dolby software components.  you have to use DriverStore Explorer [rapr.exe] to do that - remove anything Dolby related with the DriverStore Explorer app before installing the newer version with either pnputil.exe or DriverStore Explorer (rapr.exe).

 

I try DDU + Rapr.exe, uninstalled all Dolby components except one ext.inf that was locked and not uninstalled, I use Rapr.exe to add Kepler driver but still not Dolby app available on the system, no Dolby entries on start

The situation is that

Annotazione-2019-06-26-200626.jpg

 

Probably Huawei locked Dolby app and the only way to update it is a Huawei package

Share this post


Link to post
Share on other sites
erp-ster7n
7 hours ago, Romagnolo1973 said:

I try DDU + Rapr.exe, uninstalled all Dolby components except one ext.inf that was locked and not uninstalled, I use Rapr.exe to add Kepler driver but still not Dolby app available on the system, no Dolby entries on start

The situation is that

Annotazione-2019-06-26-200626.jpg

 

Probably Huawei locked Dolby app and the only way to update it is a Huawei package

I also need a screenshot of Device Manager (devmgmt.msc) to see if any Dolby components are installed.

also you have to run rapr.exe with Administrative privileges (perhaps that's why I have UAC disabled using Winaero tweaker on most of my Win10 systems so I can run certain apps like Rapr.exe with full Admin rights)

If Huawei the manufacturer decides to issue a newer Realtek + Dolby driver update for your computer, it will be a long time (maybe a month or two or longer) since driver updates from them will be hard to come by (or be less frequent).  You could try contacting them to see if they will issue a newer driver though it may be a longshot.

I also forgot to mention last time that Dolby Atmos has issues/problems working with latest Win10 version 1903😞

Quote

Audio not working with Dolby Atmos headphones and home theater

After updating to Windows 10, version 1903, you may experience loss of audio with Dolby Atmos for home theater (free extension) or Dolby Atmos for headphones (paid extension) acquired through the Microsoft Store due to a licensing configuration error.
 
This occurs due to an issue with a Microsoft Store licensing component, where license holders are not able to connect to the Dolby Access app and enable Dolby Atmos extensions.
 
To safeguard your update experience, we have applied protective hold on devices from being offered Windows 10, version 1903 until this issue is resolved. This configuration error will not result in loss of access for the acquired license once the problem is resolved.
 
Affected platforms:
  • Client: Windows 10, version 1903
 
Next steps: We are working on a resolution for Microsoft Store and estimate a solution will be available in mid-June.
Note We recommend you do not attempt to manually update using the Update now button or the Media Creation Tool until this issue has been resolved. 

this issue has not yet been resolved on Microsoft's end or MS has not yet updated their Known Issues for 1903 page as to whether or not the problem is resolved and it is already near the end of June. (perhaps Dolby themselves have to tell Microsoft if they have published updated versions of Dolby Atmos from the MS store)

Contact me by sending me a PM for any further assistance.  I will be busy downloading & recreating new installation media for Win10 v1903 that has the newer 18362.175 build rather than the earlier 1903 version from last month and will be testing them on several of my PCs.

Share this post


Link to post
Share on other sites
erp-ster7n
On 6/13/2019 at 8:42 PM, jvidal said:

run sfc /scannow to check for missing/damaged system files

I did that back then and SFC found no problems with any of the 1903 system files.  anyways, I'm back to an earlier Win10 version and will retry the 1903 upgrade using newer 1903 refresh [18362.175] install media near the end of this week

Share this post


Link to post
Share on other sites
darkblitz05

Hello guys, Im new in this forum.
I have been trying to fix the sound of my realtek lately, it just so happened that I found this forum thread that is discussing also the Realtek Audio Driver. I would like to ask for help on what to do. I know my current version is kinda late of the topic that has been discussed here in recent pages. 

Note:
My Motherboard is Asus m5a99fx Pro r2.0
Current installed Audio driver Version: Realtek 6.0.1.7848

I got the impression that when ever I used my gaming headset, its sound is just not really good its clear but its low. Even if the volume controller of the headset is already set to maximum, and in the taskbar the volume control is already set to 100/max. But if I check my desktop speakers that is plugged into the front panel of the board the sound is good and even I dont have to max out the volume control.

so my problem really is that, in using the gaming headset the sound that i can hear is not really quite good.
My other question is that, is my board's audio driver only until to version 6.0.1.7848? Because in the manufacturer site of asus, the latest audio driver version posted is 6.0.1.7848 and it came in the year of 2016.

Screenshot below:

 

I would really appreciate if anyone can help me. 

Thank you.

Capture1.PNG

Capture2.PNG

Share this post


Link to post
Share on other sites
stasio

Realtek HD Audio Driver 6.0.8742.1 WHQL

8742_FF00

Win 10  x32/64
PackageVersion = PG473
DriverVer= 06/25/2019, 6.0.8742.1

Share this post


Link to post
Share on other sites
jvidal

If anyone is interested, driver ver 8742 works on Win7 and Win81 as well (although listed as "for win 10")

Share this post


Link to post
Share on other sites
stasio
53 minutes ago, jvidal said:

If anyone is interested, driver ver 8742 works on Win7 and Win81 as well (although listed as "for win 10")

Yea,works.....but I think is not WHQL.

Share this post


Link to post
Share on other sites
stasio
On 6/26/2019 at 11:55 PM, erp-ster7n said:

unrelated note: Microsoft was very late in posting a Realtek UAD driver from May 2019 - 8699.1 (5/7/2019) on the Catalog site, MS posted this 6/24

https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.8699.1

(no Realtek UAD drivers in MS Catalog in the 8700s...yet)

Now is .....

https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.8703.1

 

Share this post


Link to post
Share on other sites
darkblitz05

I successfully updated the realtek to 6.0.8742.1
but still the audio quality of my Headset is really low.. even transferring it to the front panel and choosing HD Audio Front Panel

I dont know why is this happening..

 

Capture3.PNG

Share this post


Link to post
Share on other sites
Romagnolo1973
On 6/27/2019 at 3:51 AM, erp-ster7n said:

I also need a screenshot of Device Manager (devmgmt.msc) to see if any Dolby components are installed.

also you have to run rapr.exe with Administrative privileges (perhaps that's why I have UAC disabled using Winaero tweaker on most of my Win10 systems so I can run certain apps like Rapr.exe with full Admin rights)

If Huawei the manufacturer decides to issue a newer Realtek + Dolby driver update for your computer, it will be a long time (maybe a month or two or longer) since driver updates from them will be hard to come by (or be less frequent).  You could try contacting them to see if they will issue a newer driver though it may be a longshot.

I also forgot to mention last time that Dolby Atmos has issues/problems working with latest Win10 version 1903😞

this issue has not yet been resolved on Microsoft's end or MS has not yet updated their Known Issues for 1903 page as to whether or not the problem is resolved and it is already near the end of June. (perhaps Dolby themselves have to tell Microsoft if they have published updated versions of Dolby Atmos from the MS store)

Contact me by sending me a PM for any further assistance.  I will be busy downloading & recreating new installation media for Win10 v1903 that has the newer 18362.175 build rather than the earlier 1903 version from last month and will be testing them on several of my PCs.

Dolby Atmos Sound System is working ok on 1903, Home Teather and headphones are different programs so probably they have issue but not Atmos SS.

I made some screen about device manager situation:

1.jpg

2.jpg

3.jpg

4.jpg

Rapr at the end show a identical .inf file, the older one is what huawei locked on the system and not able tu uninstall even on safe mode, no uad, elevated privilages .... simply no way to uninstall it

 

Thake your time, if us (huawei matebook d users) need to wait Huawei new driver, it never appens ... or it will be a 2 years old one 🙂

Edited by Romagnolo1973

Share this post


Link to post
Share on other sites
jvidal
11 hours ago, stasio said:

Yea,works.....but I think is not WHQL.

nope, it is WHQL

realtek.png

Share this post


Link to post
Share on other sites
kumagaya
21 hours ago, stasio said:

Realtek HD Audio Driver 6.0.8742.1 WHQL

8742_FF00

Win 10  x32/64
PackageVersion = PG473
DriverVer= 06/25/2019, 6.0.8742.1

FF10 PLEASE

Share this post


Link to post
Share on other sites
erp-ster7n
On 6/10/2019 at 7:18 PM, aqdongo said:

 

FYI you can still download all the drivers from here (I have saved all the files in anticipating of something like this happening)

 

https://consumer.huawei.com/en/support/laptops/matebook-d-14-amd/

If you can't access it you can DL from the link below.

https://www.mediafire.com/file/sq9cdwx77dpzcab/MateBook_D_14_AMD_Audio_6.0.1.8459.zip

 

the USA ban on Huawei devices was lifted this past weekend - stories on Neowin.net here and here

 

On 6/28/2019 at 4:35 PM, kumagaya said:

FF10 PLEASE

FF10 not available for 8742.1, kumagaya.  Realtek did not produce it

 

On 6/15/2019 at 4:51 PM, DmiTrah said:

Hey . Can you also do 6.0.8726.1? or for xiaomi mi notebook pro 15.6. thanks

hardware ID of your Realtek audio device on xiaomi, DmiTrah?  8726.1 or higher, no.  8721, maybe since that is the latest generic UAD.

unrelated note - 8710.1 from MS Update Catalog (MS posted this one very late near the end of June)

https://www.catalog.update.microsoft.com/Search.aspx?q=6.0.8710.1

 

 

Share this post


Link to post
Share on other sites
stasio
On 6/29/2019 at 2:29 AM, jvidal said:

nope, it is WHQL

realtek.png

Win 7 or Win 8.1...?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...