Jump to content
LaptopVideo2Go Forums
quipster

ERROR: MXM Structure not found or invalid. Reflash MXM ROM or add MXM structure and associated callbacks to SBIOS! Final Solution to 30 Secs startup

Recommended Posts

Guest Ali

Hello. upgraded graphics card but I got the following error message:

ERROR: MXM structure not found or invalid.

Reflash MXM ROM or add MXM Structure and associated callbacks to SBIOS! POST will be halted for 30 seconds and performance will be limited to balanced performance mode until this is resolver...

notebook is acer aspire 5710g.

graphics card is nvidia geforce 9600m gt 512mb ddr3 and my rom: yedek.rom

Please save me, this will beep

Share this post


Link to post
Share on other sites
.NetRolller 3D

@Ali: Can you please do the following?

1. Download and run RW-Everything. (V1.5 should work fine.)

2. In RW-Everything, select "Memory".

3. In the memory dump window, select "Save as binary" (Shift+F2)

4. Enter 00000000 for Start Address, 000FFFFF for End Address, and 00100000 for Length. Save the resulting binary file.

5. Upload the binary file (should be exactly 1 MB in size) to ifile.it, and PM me the link. Also include the version number of the BIOS you are using, and any BIOS mods you have installed.

This should allow me to make a SBIOS mod to fix this issue properly.

Edited by .NetRolller 3D

Share this post


Link to post
Share on other sites
.NetRolller 3D

Dang, the one from above has expired.

Take this one:

https://rapidshare.com/files/461413436/Modded96.rom

Next time use ifile.it

BTW, does this properly fix the problem, or did you just copy the "Extra" clocks to the "Throttle" field to get full clock speed?

Share this post


Link to post
Share on other sites
Guest quipster

No, this also reduces the 30 secs Countdown to 1 sec. However, you still have to adjust the clocks with NiBitor,

as it isn't a "real" SBIOS fix. I'm not savvy enough to perform a real SBios Mod.

Share this post


Link to post
Share on other sites
Guest_Ali_

@ Ali:

The modded bios from the link above should work without problems:

https://rapidshare.com/files/460641968/modG96.rom

As always, flash at your own risk.

hi quipster. I received the following error message

WARNING: firmware image pci subsystem id <10de.0567> does not match adapter pci subsystem id <1a46.1405>

ERROR: PCI subsytem id mismatch

Edited by Guest_Ali_

Share this post


Link to post
Share on other sites
ImDesigner

Hello. I have 9600m gs with 512mb vram on green pcb. I know that bios from the same or similar card was modded here but link has expired. In case of that my card is not the same, here is the bios file:

https://rapidshare.com/#!download|242l32|4240655656|G96_M.bin|65

BTW: Timjak's method is better than the old one?

Share this post


Link to post
Share on other sites
ImDesigner

Alright, there's no need to worry about me. :P

I've modded and flashed card on my own. It's not difficult, but need to be careful doing this.

Share this post


Link to post
Share on other sites
fpwjay

I need a new link for an Acer 9600m GS DDR2 512meg PLEASE. I have the annoying countdown and beep. Other links in this thread do not work. Can you also add default timings????

I have also uploaded my bios

G96 M.bin

Share this post


Link to post
Share on other sites
avati

Hello everybody,

i need badly a vga bios dump of an G96-630-C1 with 1gb DDR2.

This is an nvidia 9600m gt video card. Please be carefull your nvidia chip to be an G96-630-C1.

Post also your Hardware ids from the Device manager(menu details) and the nvidia drivers you use.

After you upload it i hope to fix then the 30sec error.

Thank you in advance...

Share this post


Link to post
Share on other sites
Guest Guest

hello

i hve amilo pi 1536 gf 9500M GS and ERROR: MXM Structure not found or invalid. Reflash MXM ROM or add MXM structure and associated callbacks to SBIOS! Final Solution to 30 Secs startup please help i need mod bios

you need to flash 8600gt bios according to your memory

Share this post


Link to post
Share on other sites
quipster

http://www.filedropper.com/g96mod

Here you go, no delay, no beeping:

Also adjusted the clockrates for full performance in throttled 3D state.

As always, flash at your own risk.

Share this post


Link to post
Share on other sites
dielatin

Hello.

I have Aspire 5520 with 9600m gt 1gb ddr2 vga and Win7 64bit.

I follow the instructions with hex editor and now i have 1 sec delay in post.

With NiBiTor i change the core, shader and memory settings.

I think its all ok, but the windows can't recognise my vga (typical vga only).

I download nvwi.inf and manage finaly do setup with 301.42 nvidia drivers

but after reboot i get blue screen.

I forced unistall them in safe mode.

I have again typical vga grafics.

Edited by dielatin

Share this post


Link to post
Share on other sites
quipster

Have you tried any older drivers? Newer driver does not necessarily mean more compatible, quite the contrary...

Share this post


Link to post
Share on other sites
dielatin

quipster thanks for the answer.

I don't think this blue screen is from drivers, but i will try.

Share this post


Link to post
Share on other sites
dielatin

quipster same again with others older drivers. :dontknow:

Share this post


Link to post
Share on other sites
Pyro69

Hi quipster,

I'm trying to Upgrade My Gateway M685E nVidia Geforce Go 7600 to nVidia Geforce 9700m GT

and get

ERROR: MXM Structure not found or invalid. Reflash MXM ROM or add MXM structure and associated callbacks to SBIOS! Post will be halted for 30 seconds and peformance will be limited to balanced performance mode until this is resolved...

and it's also failed to install nVidia driver too.

please, realy need help

Thanks before.

http://novafile.com/y37qcnonor27

Edited by Pyro69

Share this post


Link to post
Share on other sites
quipster

http://www.file-upload.net/download-6728048/G96mod.rom.html

Here you go, no delay, no beeping and adjusted clock speeds.

As always, flash at your own risk.

For drivers, you may need a moddified inf, some versions work out of the box.

simply try around a bit.

Share this post


Link to post
Share on other sites
Pyro69

Very Big Thanks quipster,...

Will try it shortly

by the way, can you point more detail .inf modd you're talking about,

since I already try to modd the driver pack using DH Mobility Modder.NET nVidia Edition

and the result

266.58_notebook_winxp_32bit_international_whql.exe > error / Failed to install driver

181.22_geforce_winxp_32bit_english_whql.exe > error after / Failed after installing some .dll

VGA_Nvidia_86.02_XPx86x64 > no luck ended with BSOD after finishing install and no driver after reboot

so may be you can give me other perspective ( I'm a newbie as you see at my avatar :) )

Sometimes wondering about subsystem id,....

Edited by Pyro69

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...