Jump to content
LaptopVideo2Go Forums

GF 8400M slow Aero performance


kecinzer

Recommended Posts

This problem is not caused by Dell QuickSet. I do not use QuickSet, and I still had the problem when I was using Vista. I should have said to modify the registry instead of the INF.

Link to comment
Share on other sites

  • Replies 124
  • Created
  • Last Reply

Top Posters In This Topic

  • Michael Marley

    13

  • kecinzer

    42

  • P.J

    10

After I change INF driver is installed properly, but I have still freaky AERO performance.

But I think, that problem is not the Powermizer, because frequency is 400 / 400 MHz (by modding INF) (full performance of my GF8400). And because this I don't understeand why is happening slow performance.

Link to comment
Share on other sites

Guest Chris
After I change INF driver is installed properly, but I have still freaky AERO performance.

But I think, that problem is not the Powermizer, because frequency is 400 / 400 MHz (by modding INF) (full performance of my GF8400). And because this I don't understeand why is happening slow performance.

I see the same issue. I've modded the INI to disable powermizer (and also hacked the registry as per "Disable PowerMizer **Tested** thread suggestion). I can confirm that both the GPU core and memory clock speed is running a full 400MHz. Aero scrolling performance is still crappy. I think it's a Dell Vostro 1500 issue as I don't see anyone else using the GF8400 card complaining about this issue. Maybe Dell is doing something "funny" with its configuration in the 1500's. Maybe a product recall is in order!

Link to comment
Share on other sites

I have a Precision M4300 with a Quadro FX360M and I have exactly the same problem. 101.19 is fine and 156.xx is not. I have not tried any driver in between.

I have although contacted Dell support and got no valuable help there.

I think has nothing to do with Powermizer as the working driver although throttles the GPU in the same way as the newer versions (used GPUZ to verify).

I mostly see the problem when using text heavy applications (Browser and more obvious in a text editor).

I already tried to disable powermize but it didn't help any. I think Dell is doing something silly with their drivers.

-Andi

Link to comment
Share on other sites

I hope, that we find solution for this problem.

When I have any time, I try install fresh OS Vista 64 on external disk or something like that, and Install only graphic driver on fresh system. Because I think, that this behavior is because driver collison or else.

Or for saving my time, can you someone tryed on fresh system?

Link to comment
Share on other sites

I have done some troubleshooting and I have found that if, when the video card is in 2D mode, I "overclock" the video card RAM back to its normal level (without touching the GPU clocks) that the problem goes away. Now, if only there was a way to disable memory clock changes without disabling PowerMizer.

Link to comment
Share on other sites

I have done some troubleshooting and I have found that if, when the video card is in 2D mode, I "overclock" the video card RAM back to its normal level (without touching the GPU clocks) that the problem goes away. Now, if only there was a way to disable memory clock changes without disabling PowerMizer.

How did you overclock just your video ram?

BTW. I didn't manage to turn off powermizer for 101.19 or any other driver that I tried. Any pointers?

-Andi

Link to comment
Share on other sites

I did not really overclock it. What I did was I installed RivaTuner and used it modify the RAM clock speed for 2D mode. I then changed it back to the default RAM speed of my card without changing the GPU speed. I then waited for PowerMizer to down-throttle the card, and tested Aero. It worked fine. However, this is not a permanent solution because it requires RivaTuner to run whenever your system boots or resumes from sleep/hibernate.

Link to comment
Share on other sites

One more note. I have disabled powermizer as described in that thread. When checking the frequencies with GPU-Z I still see the downclocked frequencies but the jerkyness of Aero is gone now. Very strange...

At the moment I'm still using 101.19. I will try the solution with Rivatuner and 'overlocking' the memory frequency later.

@Michael: Have you tried the scrolling test with IE or Firefox? when 'overclocking' the memory?

-Andi

Link to comment
Share on other sites

The scrolling in Firefox is still perfectly smooth with the memory "overclocked" to 400mHz. If I just knew of some way to disable memory throttling in the INF, then we could still enjoy some power savings without having to endure the jerkiness.

EDIT: I did some more testing, and found that it still runs smoothly at 200mHz, which is the "Low Power 3D" powermizer stage. So if we could find a way to disable the lowest power mode, that would also help.

Link to comment
Share on other sites

is your vista rating index for your system 3.6? mines 3.6 and it lags a bit when i scroll down aswell but it is only if you use the scroll button on your mouse, if you drag your bar down using your cursor then it should be fine

Link to comment
Share on other sites

Guest Guest

My Dell 1420 gets a 3.7 on Aero, you know whats fun... Open a few windows and flip aero 10-15 times and watch your slow performance disapear. The 8400m GS needs to warm up and it downclocks when not used. I hate it!

Link to comment
Share on other sites

So, is there any solution for this scrolling bug? I have tried turn off powermizer - Aero is faster, but scrolling not. And without powermizer is my laptop warm.

With 101.19 is frequency so slow, but scrolling si smooth.

Link to comment
Share on other sites

There isn't one, as far as I know. My problem goes away when I turn off PowerMizer.

Link to comment
Share on other sites

I GOT THE SOLUTION, BEFORE INSTALLING THE DRIVERS YOU HAVE TO DESACTIVATE "powermizer"

Go in nv_disp.inf and find the line powermizer enable then put 0 instead of 1

!!!

woah slow down man dont crap yourself

Link to comment
Share on other sites

Have you someone tryed this issue on fresh OS?

Only install Vista and then drivers. I have not much time for do that.

Link to comment
Share on other sites

Guest Chris

I've raised this issue with Dell support. After a few discussions its been elevated to one of their Microsoft Certified Engineers which in turn has raised it with the "ISP Team" (not sure what that is) who can leverage Nvidia for input.

My problem report and their response below. I'll keep you all posted on any progress:

Summary:

Poor application scrolling performance when Aero is enabled on a Vostro 1500 with GF 8400M card.

Description:

I am writing to raise a software driver performance issue with Dell. The drivers shipped by Dell for the GeForce 8400M card has a serious performance regression. This manifests itself as poor "laggy" scrolling performance in any application window when Vista Aero is enabled.

Steps to Reproduce:

1) On a Dell Vostro 1500 with a GF 8400M card, open a web page containing lots of text (multiple pages) and maximize to full screen.

2) Scroll the page up and down using the slider - notice the laggy and jumpy performance.

3) Change the Windows theme appearance setting to "Windows Vista Basic" - i.e. turn off Aero with compositing.

4) Repeat step 2 and notice the improvement

Expected Behavior:

The scrolling performance should be much better with Aero enabled. The performance of my 3-year-old Dell laptop is many times better. Performance should be equivalent to "Windows Vista Basic" theme.

Reproducibility:

Always. The issue is also repeatable on other Vostro 1500 Notebooks purchased by our company. One of our developers is also a contributor to the Linux Kernel (Video for Linux drivers) and has confirmed that in his opinion that this is a Windows Video Card driver related performance regression.

Known Workarounds:

No practical solution. The following non-practical solutions have been found:

1) Downgrade to very old driver prior to Nvidia forceware version 101.19 seems to resolve the issue. These very old drivers however are "buggy" and cause numerous problems with other applications - e.g iTunes hangs.

2) Use Rivatune.exe to upclock the memory speed then wait a few minutes, then change from Vista Basic to Aero. Repeat this a few times and eventually Aero will start working as expected with acceptable performance! The problem however returns again after system reboot or hibernate.

Action Required To Resolve Issue:

Investigation suggests it's a driver/software related issue specific to Dell's configuration of the GF8400 card. The issue will only be resolved by Dell raising the issue at the highest technical level with Nvidia - e.g. your Nvidia OEM technical contact. A driver update will be required.

Further Reading:

There is some public discussion on this issue in the following forum thread:

http://forums.laptopvideo2go.com/index....5&st=0&

All technical solutions raised on the laptopvideo2go.com forum thread have been investigated.

Dell's Reponse to date:

Thanks for the very detailed account of your troubleshooting steps and the issue at hand.

I will take this issue up with the IPS team we have, and ask for some resolution.

The team is based in the United States, so I will not hear back from the team straight away.

I will keep you informed of the feedback once I receive it. This team can leverage Nvidia for input also.

Link to comment
Share on other sites

WOW, thanks for detailed report.

I will hope, that Dell solve this problem.

Link to comment
Share on other sites

Well, I tryed install fresh system Vista 64 SP1 and still same problem.

This problem is appearing on all versions Vista? I mean 32bit, 64bit and what about SP1? I dont tryed on system without SP1 and I not plan that.

Is there someone, who tested it on Vista without SP1?

Link to comment
Share on other sites

Back when I used Vista, I noticed the problem occurred with RTM as well. In fact, RTM performance was much slower than SP1 performance. If I were you, I would just switch to XP x64. I did.

Link to comment
Share on other sites

I believe the problem is that enabling AERO also enables vertical sync from window's GDI (Graphic display interface).

Take notice that, when running a basic theme, when you scroll through text - although it scrolls smooth and responsively - the text may be a little jumpy and moving around windows will result in horizontal tearing. Enabling AERO fixes the tearing, but brings in annoying lag and jumpyness of scrolling and Windows Switcher

I have the same annoying lag with the scrolling and poor performance with Windows Switcher on my 8600M GT on DELL 1520. This problem fairly widespread, I don't remember having any problems when I first got it and was using older drivers, but nowadays it works really badly in AERO and I have since switches to Windows XP.

Link to comment
Share on other sites

  • 2 weeks later...
Guest Chris

Just to give everyone an quick update. After a bit of back and forward with Dell (e.g. screen-shots of settings, testing with ram removed and ruling out application level issues), Dell have finally confirmed that they are able to reproduce the problem and have indicated they they also believe it's a driver problem. The issue has been re-elevated with their IPS team and they are going to keep me informed with updates very few days. I'll keep everyone posted as I receive any news.

Link to comment
Share on other sites

Well, it's good that dell acknowledges something (that must have taken some time.) That problem must have been driver related. This should be resolved in a later driver release hopefully if it hasn't been already, with 177.66 or 177.72.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...